Can't get PATCH to work

Hi,

I am not able to get PATCH method work. What is the best way to get PATCH method work? I am getting method not supported.

Tried using POSTMAN

Tried using localhost:5601 kibana dev tools

Regards,

Pankaj

When asking questions, please provide the following information:

  • Search Guard and Elasticsearch version - Search Guard : 6-6.4.2-23.1 and Elastic Search 6.4.2

  • Installed and used enterprise modules, if any

  • JVM version and operating system version : 1.8.0_121

  • Search Guard configuration files

  • Elasticsearch log messages on debug level

  • Other installed Elasticsearch or Kibana plugins, if any

sg_config.yml (9.41 KB)

For PATCH to work, you need the latest SG version 23.2. I will make that more clear in the documentation.

···

On Tuesday, November 20, 2018 at 12:55:27 PM UTC+1, pankaj chand wrote:

Hi,

I am not able to get PATCH method work. What is the best way to get PATCH method work? I am getting method not supported.

Tried using POSTMAN

Tried using localhost:5601 kibana dev tools

Regards,

Pankaj

When asking questions, please provide the following information:

  • Search Guard and Elasticsearch version - Search Guard : 6-6.4.2-23.1 and Elastic Search 6.4.2
  • Installed and used enterprise modules, if any
  • JVM version and operating system version : 1.8.0_121
  • Search Guard configuration files
  • Elasticsearch log messages on debug level
  • Other installed Elasticsearch or Kibana plugins, if any

Thanks. I will update search guard. Also is there any plan to support JWE? It will be good if JWE is supported. Our auth component uses JWE.

Regards

Pankaj

···

On Tuesday, November 20, 2018 at 9:52:43 PM UTC+5:30, Jochen Kressin wrote:

For PATCH to work, you need the latest SG version 23.2. I will make that more clear in the documentation.

On Tuesday, November 20, 2018 at 12:55:27 PM UTC+1, pankaj chand wrote:

Hi,

I am not able to get PATCH method work. What is the best way to get PATCH method work? I am getting method not supported.

Tried using POSTMAN

Tried using localhost:5601 kibana dev tools

Regards,

Pankaj

When asking questions, please provide the following information:

  • Search Guard and Elasticsearch version - Search Guard : 6-6.4.2-23.1 and Elastic Search 6.4.2
  • Installed and used enterprise modules, if any
  • JVM version and operating system version : 1.8.0_121
  • Search Guard configuration files
  • Elasticsearch log messages on debug level
  • Other installed Elasticsearch or Kibana plugins, if any

JWE will very likely be supported with SG7

···

Am 21.11.2018 um 06:52 schrieb pankaj chand <pankaj.iitm@gmail.com>:

Thanks. I will update search guard. Also is there any plan to support JWE? It will be good if JWE is supported. Our auth component uses JWE.

Regards
Pankaj

On Tuesday, November 20, 2018 at 9:52:43 PM UTC+5:30, Jochen Kressin wrote:
For PATCH to work, you need the latest SG version 23.2. I will make that more clear in the documentation.

On Tuesday, November 20, 2018 at 12:55:27 PM UTC+1, pankaj chand wrote:
Hi,

I am not able to get PATCH method work. What is the best way to get PATCH method work? I am getting method not supported.

Tried using POSTMAN
Tried using localhost:5601 kibana dev tools

Regards,
Pankaj

When asking questions, please provide the following information:

* Search Guard and Elasticsearch version - Search Guard : 6-6.4.2-23.1 and Elastic Search 6.4.2
* Installed and used enterprise modules, if any
* JVM version and operating system version : 1.8.0_121
* Search Guard configuration files
* Elasticsearch log messages on debug level
* Other installed Elasticsearch or Kibana plugins, if any

--
You received this message because you are subscribed to the Google Groups "Search Guard Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/8cd1c7ca-5883-4373-a811-0c29e4f12f7f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.