Problems with ELK + elasticsearch + kibana + search guard + pluggin

Hi guys!! im very new in the world of ELK,

I have installed a new and clean ubuntu 18.0 server, I have downloaded and installed elasticsearch version 7.6.0 and kibana 7.6.0, after basically configuring it:

elasticsearch.yml /var/lib/elasticsearch

path.logs: /var/lib/elasticsearch 123.45.657.89

http.port: 9200

discovery.seed_hosts: [“123.45.657.89”, “host2”]

kibana.yml “123.45.657.89”

elasticsearch.hosts: [“http://123.45.657.89:9200”]

After that, I have configured the automatic startup of the services

sudo systemctl enable elasticsearch sudo systemctl enable kibana

sudo systemctl start elasticsearch sudo systemctl start kybana

At this point it worked fine, I could get through the browser to the kibana configuration panel without any problem.

The shit starts when I wanted to install searchguard plogin to put a security kit [Just some credentials for kibana and elasticsearch]

I have installed it as follows:

I downloaded from the official repository the pluggin of elasticsearch, specifically this one:

I have passed it to my vm and installed it as follows:

cd /usr/share/kibana

bin/kibana-plugin install file:usr/share/kibana/ --allow-root

and installed it correctly.

The installation of the plugin I have done with the service of elasticsearch and kibana stopped

Then I restarted them and the services were active

BUT… my problem is that now kibana doesn’t work, I try to enter through the browser and the screen stays like this:

Kibana server is not ready yet

Have I missed any settings? How did you finish setting the password?

Any help is welcome, all the information I find is diffused.

To enable security, you have to install two Search Guard plugins: one for Elasticsearch and one for Kibana.

Start with the quick start guide. ATTENTION! This guide is for demo only, change the credentials to make it secure. Also, read more documentation to find out how can you tune security.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.