Missing Signal plugin 7.7.0

If you think it is a bug report or you have a technical issue, please answer the following questions. For general questions, you can delete these questions.

Elasticsearch version:
7.7.0

Server OS version:
CentOS

Kibana version (if relevant):
7.7.0

Describe the issue:
After upgrade from 7.4.0 to 7.7.0, as per documentation signals should be enabled by default but seems to be missing

Steps to reproduce:
1.Upgrade 7.4.0 -> 7.7.0
2. Kibana UI does not show signals plugin

Expected behavior:
signals plugin UI visible

Find SIgnals on the Kibana left nav bar. See number 1 on the screenshot

https://search-guard.com/signals-elasticsearch-alerting/

Sorry, may be my question was misleading… I meant the signals tab is missing. Confirmed I am admin role.

Do I need to add specific roles for Signals in my sg-roles? as that might be reason the plugin is not visible

Right, Signals should be available by default. You can run this docker environment to check it https://git.floragunn.com/search-guard/search-guard-labs

If you upgraded, make sure you have the proper Signals permissions.

I tried using UI, do we have to do using sg-admin only or UI is fine?

Tenant

and Cluster

It is a bug in UI. It will be resolved this month during the current release.

As a temporary solution, could you set the permissions in sg_roles.yml and use sgadmin to apply the change?

When you say current release means ( 42.0.0 )? or next one… as I saw it was released yesterday…

Will try using permissions in sg_roles.yml and use sgadmin

Is it possible to share the sample permissions of sg_roles for Signals

You can close this ticket, it worked using sg-admin tool

I’m glad it worked for you. I leave the ticket open as a reference to this UI bug.

I meant the release we have in the first part of July.