Kibana Saved Object URL return 404


We recently upgraded ELK stack from 7.4.0 to 7.7.1. Now we notice that none of the shortened URL’s work. They always return a 404. This is the error message we get in the browser:

  statusCode: 404, 
  error: "Not Found",
  message: "Saved object [url/754cb178d86a01093fd9f80f507344e7] not found"

Additional Info: We use Kibana multitenancy.

Elasticsearch version:

Kibana version (if relevant):


1 Like

@srgbnd I also notice this similar issue when you are in same tenant.

Steps by which the Short URL work

  1. Switch to tenant A
  2. Generate Short URL …
  3. Try to reach above Short URL … got same error - 404
  4. Switch to tenant B
  5. Try to reach above Short URL… and it works now.
  6. Thus something to do with switching tenant

Hi there,

I’ve tested and can confirm this issue. It seems like a regression in how mutltitenancy checks whether or not to assign a tenant request header.

I’ll look into this some more and try to implement a fix.

Thanks for reporting!
Best Regards

Do we know when, the fix would be released? :sweat_smile:

We will have the fix in the next release, scheduled for July 7.

However, we should be able to provide you a snapshot build based on the latest release, but with the bugfix included. I’m working on this right now.

Alternatively, if you have access to the code, this is the offending change:

The error can be fixed by changing that line back to:
if (!request.path.startsWith("/elasticsearch") && !request.path.startsWith("/api") && !request.path.startsWith("/app") && request.path != "/" && !selectedTenant) {

But I’ll try to get a build ready and the update this issue.

Sorry for the inconvenience!

Thank you for the response Mike. Snapshot should be sufficient for us.

Along the same lines, I am also facing this bug mentioned in another post: Missing discoverQueryHits in kibana UI
I was wondering if that fix can be included in the snapshot too.

Thank you!

Thanks @Mike do you know if this is just Kibana plugin patch or we have to apply on all the data nodes, master too?

This should just be a Kibana plugin patch, no need to change the nodes.

So, unless I’ve done something wrong, this issue should have a snapshot release for 7.7.1-42.1.0 attached, which includes fixes for the tenant problem, and also the missing hits in Discover.
//cc @mchakradeo

Please let me know if things don’t work, and I’ll take a look at it.

Best Regards

1 Like

Here we go:


Thank you for the quick turnaround!
I will test out the new image.

Hey Mike, that did the job for us. Thanks again!