User Profile in Kibana not visible anymore while proxy authentication?

Hi guys,

I’ve setup the proxy authenticaiton towards kibana. It works so far in the searchguard gui i can see that I am logged in with the corresponding user passed in the header using x-proxy-user.
image

The only thing I miss now is the user profile overview in the right upper corner here so i can see that I am logged in with my user:

image

Do you have any idea if I can enable this somehow or is it gone forever when I use proxy authentication?

Thanks

Hi @Kosmonafft
You can see the full user name when you click on the icon, can’t you?
Screenshot 2020-06-09 at 18.14.46

The old look was deprecated. Because it messed up the top navbar when there was a very long user name. Also, we (SG) need to have some global space to show some more user-related data in the future.

Thank you for your answer. Yes that what I’d expect. But in my kibana I do not see this icon anymore after I have enabled proxy authenticaiton:

The only place where I can see what user I have been logged in is in this searchguard gui user overview as you can see on the first screenshot in my first post.

Ok, I understand your point. I looked at the code and saw it was designed to work this way

if (authType !== 'kerberos' && authType !== 'proxy') {
  chromeHeaderNavControlsRegistry.register($http => {

Because we can’t logout when authenticated via Kerberos or proxy. But we can render username there without the logout link if the Kerberos or proxy. I add this to the feature queue.

Btw, the contribution is highly welcomed. If you want you can pull the repo, develop the feature, do the pull request and we merge if it works.

Alright, thanks for the clarification!