unable to set index level permission searchguard

Hi Team,

I am getting below issue:

[security_exception] no permissions for [indices:data/read/search] and User [name=ajitnew, roles=[sg_kibana_user], requestedTenant=null, attributes={}]

sg_internal_users.yml

amit:

hash: $2y$12$oxNBLRDHhKimu35tKIJ5y.mzlTxGSaPwQBAE5pyNdMZnaNF83bKk.

roles:

  • sg_amitrole

sg_roles.yml

sg_amitrole:

cluster:

  • CLUSTER_COMPOSITE_OPS_RO

indices:

‘testnewindex’:

‘testtype’:

  • indices:data/read/search

sg_roles_mapping.yml

sg_amitrole:

users:

  • amit

where user is: amit, custom role is: sg_amitrole, index name is: testnewindex.

nothing is showing after login with amit.It is showing error for index level permission.

searchguard,elasticsearch and kibana version is 6.0.0

you are logged in as ajitnew, not as amit

···

Am 22.01.2018 um 15:44 schrieb kanchankachare88@gmail.com:

Hi Team,

I am getting below issue:

[security_exception] no permissions for [indices:data/read/search] and User [name=ajitnew, roles=[sg_kibana_user], requestedTenant=null, attributes={}]

sg_internal_users.yml

amit:
  hash: $2y$12$oxNBLRDHhKimu35tKIJ5y.mzlTxGSaPwQBAE5pyNdMZnaNF83bKk.
  roles:
    - sg_amitrole

sg_roles.yml

sg_amitrole:
  cluster:
    - CLUSTER_COMPOSITE_OPS_RO
  indices:
    'testnewindex':
      'testtype':
        - indices:data/read/search

sg_roles_mapping.yml

sg_amitrole:
  users:
    - amit

where user is: amit, custom role is: sg_amitrole, index name is: testnewindex.

nothing is showing after login with amit.It is showing error for index level permission.

searchguard,elasticsearch and kibana version is 6.0.0

--
You received this message because you are subscribed to the Google Groups "Search Guard Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/2ba42ee9-0b1a-40c0-a0ae-861b5a40eee5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

sorry, the user is amit there.

···

On Monday, 22 January 2018 21:22:46 UTC+5:30, Search Guard wrote:

you are logged in as ajitnew, not as amit

Am 22.01.2018 um 15:44 schrieb kanchank...@gmail.com:

Hi Team,

I am getting below issue:

[security_exception] no permissions for [indices:data/read/search] and User [name=ajitnew, roles=[sg_kibana_user], requestedTenant=null, attributes={}]

sg_internal_users.yml

amit:

hash: $2y$12$oxNBLRDHhKimu35tKIJ5y.mzlTxGSaPwQBAE5pyNdMZnaNF83bKk.

roles:

- sg_amitrole

sg_roles.yml

sg_amitrole:

cluster:

- CLUSTER_COMPOSITE_OPS_RO  

indices:

'testnewindex':
  'testtype':  
    - indices:data/read/search

sg_roles_mapping.yml

sg_amitrole:

users:

- amit

where user is: amit, custom role is: sg_amitrole, index name is: testnewindex.

nothing is showing after login with amit.It is showing error for index level permission.

searchguard,elasticsearch and kibana version is 6.0.0


You received this message because you are subscribed to the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/2ba42ee9-0b1a-40c0-a0ae-861b5a40eee5%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.