Tab icons missing when in Search Guard menu in 6.x-24.0/6.6.0+

When asking questions, please provide the following information:

  • Search Guard and Elasticsearch version - behavior observed in SG: com.floragunn:search-guard-6:6.6.0-24.1 and com.floragunn:search-guard-6:6.6.0-24.1. ES: 6.6.0 and 6.6.1

  • Installed and used enterprise modules, if any - none

  • JVM version and operating system version:

openjdk version “1.8.0_191”

OpenJDK Runtime Environment (build 1.8.0_191-b12)

OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)

sg_config.yml (9.74 KB)

sg_roles.yml (4.07 KB)

sg_roles_mapping.yml (684 Bytes)

kibana SG logs.txt (39 KB)

sg_action_groups.yml (2.31 KB)

···

CentOS Linux release 7.6.1810 (Core)

  • Search Guard configuration files - attached

  • Elasticsearch log messages on debug level - doesn’t seem appropriate here, since this is related to the Kibana plugin. attached Kibana logs.

  • Other installed Elasticsearch or Kibana plugins, if any - none

Does anyone else experience the tab icons missing after selecting the Search Guard tab in Kibana dashboard? Is this an intended behavior?

Things attempted:

  • Log in as LDAP admin. Log in to replicate as local admin account.

  • Clear browser cache.

  • Incognito browser tab.

  • Different browsers.

  • Purge Cache from Search Guard option in Kibana dashboard.

When a Kibana dashboard option is selected, the icons/tabs look like this:

2019-02-28 09_22_39-Discover - Kibana.png

When the Search Guard tab is selected in the Kibana dashboard, the icons/tabs look like this:

2019-02-28 09_23_28-Kibana.png

I’ve not seen this issue yet, but it could be related to an unsuccessful optimization process during plugin installation.

In the top-level directory of Kibana, you will find a folder called optimize. This is where webpack stores the optimized bundles for all Kibana applications. Can you try to:

  • stop Kibana

  • remove this folder completely

  • start Kibana

You should see the optimization process kick in, might take a while for it to complete. After the optimize process has finished, log in to Kibana and see if the issue is fixed.

···

On Thursday, February 28, 2019 at 7:00:39 AM UTC-8, mattsdevop@gmail.com wrote:

When asking questions, please provide the following information:

  • Search Guard and Elasticsearch version - behavior observed in SG: com.floragunn:search-guard-6:6.6.0-24.1 and com.floragunn:search-guard-6:6.6.0-24.1. ES: 6.6.0 and 6.6.1
  • Installed and used enterprise modules, if any - none
  • JVM version and operating system version:

openjdk version “1.8.0_191”

OpenJDK Runtime Environment (build 1.8.0_191-b12)

OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)


CentOS Linux release 7.6.1810 (Core)

  • Search Guard configuration files - attached
  • Elasticsearch log messages on debug level - doesn’t seem appropriate here, since this is related to the Kibana plugin. attached Kibana logs.
  • Other installed Elasticsearch or Kibana plugins, if any - none

Does anyone else experience the tab icons missing after selecting the Search Guard tab in Kibana dashboard? Is this an intended behavior?

Things attempted:

  • Log in as LDAP admin. Log in to replicate as local admin account.
  • Clear browser cache.
  • Incognito browser tab.
  • Different browsers.
  • Purge Cache from Search Guard option in Kibana dashboard.

When a Kibana dashboard option is selected, the icons/tabs look like this:

When the Search Guard tab is selected in the Kibana dashboard, the icons/tabs look like this:

I was able to complete the steps. Unfortunately, that did not change anything. Tried clearing browser cache, incognito window, and other browsers again. Is there any other information that I can provide that would help in getting to the bottom of this? This was an upgrade from 6.5.4, which was showing the icons in that version. Once the version was upgraded to 6.6.0 along with the Search Guard plugin, it was introduced. Thinking that 6.6.1 might resolve it, I’ve upgraded it to 6.6.1, which is where we sit right now.

···

On Thursday, February 28, 2019 at 5:32:25 PM UTC-5, Jochen Kressin wrote:

I’ve not seen this issue yet, but it could be related to an unsuccessful optimization process during plugin installation.

In the top-level directory of Kibana, you will find a folder called optimize. This is where webpack stores the optimized bundles for all Kibana applications. Can you try to:

  • stop Kibana
  • remove this folder completely
  • start Kibana

You should see the optimization process kick in, might take a while for it to complete. After the optimize process has finished, log in to Kibana and see if the issue is fixed.

Hi there,

It seems like there’s a bug in Kibana that causes the icons to disappear.

https://github.com/elastic/kibana/issues/29097 and https://github.com/elastic/kibana/issues/31085

Looks like it has been fixed in an upcoming 6.6.2, but not backported to 6.6.1.

I’ll keep an eye on their progress.

Best Regards

Mike

···

On Friday, 1 March 2019 01:18:51 UTC+1, matts...@gmail.com wrote:

I was able to complete the steps. Unfortunately, that did not change anything. Tried clearing browser cache, incognito window, and other browsers again. Is there any other information that I can provide that would help in getting to the bottom of this? This was an upgrade from 6.5.4, which was showing the icons in that version. Once the version was upgraded to 6.6.0 along with the Search Guard plugin, it was introduced. Thinking that 6.6.1 might resolve it, I’ve upgraded it to 6.6.1, which is where we sit right now.

On Thursday, February 28, 2019 at 5:32:25 PM UTC-5, Jochen Kressin wrote:

I’ve not seen this issue yet, but it could be related to an unsuccessful optimization process during plugin installation.

In the top-level directory of Kibana, you will find a folder called optimize. This is where webpack stores the optimized bundles for all Kibana applications. Can you try to:

  • stop Kibana
  • remove this folder completely
  • start Kibana

You should see the optimization process kick in, might take a while for it to complete. After the optimize process has finished, log in to Kibana and see if the issue is fixed.

Hey Mike,
Nice find! Thanks for passing that along. I hadn’t found that previously.

···

On Friday, March 1, 2019 at 2:59:37 PM UTC-5, Mike wrote:

Hi there,

It seems like there’s a bug in Kibana that causes the icons to disappear.

https://github.com/elastic/kibana/issues/29097 and https://github.com/elastic/kibana/issues/31085

Looks like it has been fixed in an upcoming 6.6.2, but not backported to 6.6.1.

I’ll keep an eye on their progress.

Best Regards

Mike