Searchguard plugin compatible with Elasticsearch 6.0.0

We are using Elasticsearch 6.0.0 version. I see these are searchguard plugins on maven central repository: http://search.maven.org/#search|gav|1|g%3A"com.floragunn"%20AND%20a%3A"search-guard-6"

From their names, it sounds line compatible version of Searchguard for ES 6.0.0 is in Beta. Is there any plan to GA release Searchguard plugin compatible with 6.0.0?

Thanks,

Milind

Hi,

please see also: https://github.com/floragunncom/search-guard/issues/436

The main reason for not releasing a GA for 6.0.x was that almost all customers wanted to wait for Elasticsearch 6.1.x before upgrading their production systems. The background is bad experiences with the Elasticsearch 5.0.x line last year, and we also recommend to directly move to 6.1.x in production.

Since 6.1.1 is already out my question is - is there a reason why you can’t use 6.1.x and need the GA for 6.0.x? Because if there’s a real need, of course, we will think about shipping a GA for 6.0.x as well. Thanks!

···

On Wednesday, January 3, 2018 at 6:54:12 PM UTC+1, Mili wrote:

We are using Elasticsearch 6.0.0 version. I see these are searchguard plugins on maven central repository: http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22com.floragunn%22%20AND%20a%3A%22search-guard-6%22

From their names, it sounds line compatible version of Searchguard for ES 6.0.0 is in Beta. Is there any plan to GA release Searchguard plugin compatible with 6.0.0?

Thanks,

Milind