Search guard ssl/2 for ES version 2.2.2

Hi,

I appreciate your help!

I have an application running on Elasticsearch version 2.2.2, cannot upgrade ES version. I would like to install search guard on my Elasticsearch deployment. I am using Red hat linux version 6.6. When I tried to run bin/plugin install com.floragunn/search-guard-ssl/2.3.1.8, it gives incompatible version with Elasticsearch. Then tried with one older version of SGS- 2.2.1.7 which turns into same incompatible version error.

So, I am unable to get SGS for my ES 2.2.2. When I searched for version compatible matrix, I don’t see ES version 2.2.2 against a SGS version. Does SGS support ES 2.2.2? If not, why? Do I need to build SGS with ES 2.2.2? Then, how to build?

Please guide, how can I use Search guard for my ES 2.2.2 deployment?

Regards,

Ashu

why do you cannot upgrade?

···

Am 30.05.2016 um 20:07 schrieb 'Ashu' via Search Guard <search-guard@googlegroups.com>:

Hi,

I appreciate your help!

I have an application running on Elasticsearch version 2.2.2, cannot upgrade ES version. I would like to install search guard on my Elasticsearch deployment. I am using Red hat linux version 6.6. When I tried to run bin/plugin install com.floragunn/search-guard-ssl/2.3.1.8, it gives incompatible version with Elasticsearch. Then tried with one older version of SGS- 2.2.1.7 which turns into same incompatible version error.

So, I am unable to get SGS for my ES 2.2.2. When I searched for version compatible matrix, I don't see ES version 2.2.2 against a SGS version. Does SGS support ES 2.2.2? If not, why? Do I need to build SGS with ES 2.2.2? Then, how to build?

Please guide, how can I use Search guard for my ES 2.2.2 deployment?

Regards,
Ashu

--
You received this message because you are subscribed to the Google Groups "Search Guard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/3c6f5e7b-73f8-480a-aacf-b03dc23e9b6e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Finally, I managed to upgrade my Elasticsearch and have SG working fine with my cluster.

Thanks for the help!

Regards,

Ashu

···

On Monday, May 30, 2016 at 2:54:23 PM UTC-4, SG wrote:

why do you cannot upgrade?

Am 30.05.2016 um 20:07 schrieb ‘Ashu’ via Search Guard search...@googlegroups.com:

Hi,

I appreciate your help!

I have an application running on Elasticsearch version 2.2.2, cannot upgrade ES version. I would like to install search guard on my Elasticsearch deployment. I am using Red hat linux version 6.6. When I tried to run bin/plugin install com.floragunn/search-guard-ssl/2.3.1.8, it gives incompatible version with Elasticsearch. Then tried with one older version of SGS- 2.2.1.7 which turns into same incompatible version error.

So, I am unable to get SGS for my ES 2.2.2. When I searched for version compatible matrix, I don’t see ES version 2.2.2 against a SGS version. Does SGS support ES 2.2.2? If not, why? Do I need to build SGS with ES 2.2.2? Then, how to build?

Please guide, how can I use Search guard for my ES 2.2.2 deployment?

Regards,

Ashu


You received this message because you are subscribed to the Google Groups “Search Guard” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/3c6f5e7b-73f8-480a-aacf-b03dc23e9b6e%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.