No permissions to access REST API

Hi Search Guard Forum,

I am using Searchguard enterprise license. The problem is that for some reason when accessing:
https://localhost:9200/_searchguard/api/tenants I am getting below response:

"status": "FORBIDDEN"
"message": "No permission to access REST API: User admin with Search Guard Roles [SGS_ALL_ACCESS, SGS_OWN_INDEX] does not have any role privileged for admin access. No client TLS certificate found in request."

Does it mean that I have to include certificate to be able to access REST API? If yes can this be somehow disabled?
If this is not the case can you point me in the right direction?

By default I am using username and password when accessing Kibana.


I have notice one more thing. I am missing searchguard ui in kibana. I checked and searchguard.enterprise_modules_enabled: true

Can you share your elasticsearch.yml file?

There should be entry:
searchguard.restapi.roles_enabled: ["SGS_ALL_ACCESS"]

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.