Mismatch of username in elasticsearch and kibana

When asking questions, please provide the following information:

  • Search Guard and Elasticsearch version

  • Installed and used enterprise modules, if any

  • JVM version and operating system version

  • Search Guard configuration files

  • Elasticsearch log messages on debug level

  • Other installed Elasticsearch or Kibana plugins, if any

ES version 6.3.1
SG version 6-22.3


Facing problem with searchguard-kibana plugin.
I can see an error:


between the configured Kibana server usernames on Elasticsearch and Kibana, multitenancy will not work! Configured username on Kibana: ‘admin’, configured username on Elasticsearch: ‘kibanaserver’


searchguard.dynamic.kibana.multitenancy_enabled: true
searchguard.dynamic.kibana.server_username: “admin”
searchguard.dynamic.kibana.index: “.kibana”
searchguard.dynamic.kibana.do_not_fail_on_forbidden: false
anonymous_auth_enabled: false
enabled: false
internalProxies: ‘|’ # regex pattern
#internalProxies: ‘.*’ # trust all internal proxies, regex pattern
remoteIpHeader: ‘x-forwarded-for’
proxiesHeader: ‘x-forwarded-by’


The Kibana server’s name. This is used for display purposes.

#server.name: “your-hostname”

The URL of the Elasticsearch instance to use for all your queries.

elasticsearch.url: “https://localhost:9200

When this setting’s value is true Kibana uses the hostname specified in the server.host

setting. When the value of this setting is false, Kibana uses the hostname of the host

that connects to this Kibana instance.

#elasticsearch.preserveHost: true

Kibana uses an index in Elasticsearch to store saved searches, visualizations and

dashboards. Kibana creates a new index if the index doesn’t already exist.

kibana.index: “.kibana”

The default application to load.

#kibana.defaultAppId: “home”

If your Elasticsearch is protected with basic authentication, these settings provide

the username and password that the Kibana server uses to perform maintenance on the Kibana

index at startup. Your Kibana users still need to authenticate with Elasticsearch, which

is proxied through the Kibana server.

elasticsearch.username: “admin”
elasticsearch.password: “admin”