how to disable warning in logs

Using SG and Elasticsearch v 6.5.3, I have enabled JWT token authentication, but I still have some clients that use user:password (or other), I want to disable this message from flooding my elasticsearch logs:

[2019-03-20T15:00:44,725][WARN ][c.f.d.a.h.j.HTTPJwtAuthenticator] [isZPOIE] No Bearer scheme found in header

How can I disable that message ?

You can change the loglevel for the com.floragunn.dlic.auth.http.jwt.HTTPJwtAuthenticator class to be ERROR.

Pls. refer to https://www.elastic.co/guide/en/elasticsearch/reference/6.5/logging.html on how to do this.

We will reduce the loglevel of this particular logstatement to DEBUG in the next release

ยทยทยท

Am 20.03.2019 um 20:03 schrieb Wyllys Ingersoll <wyllys@gmail.com>:

Using SG and Elasticsearch v 6.5.3, I have enabled JWT token authentication, but I still have some clients that use user:password (or other), I want to disable this message from flooding my elasticsearch logs:

[2019-03-20T15:00:44,725][WARN ][c.f.d.a.h.j.HTTPJwtAuthenticator] [isZPOIE] No Bearer scheme found in header

How can I disable that message ?

--
You received this message because you are subscribed to the Google Groups "Search Guard Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/702f3f54-3139-4030-9763-e3bacf03a32c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.