How do i only authenticate once?

Searchguard: 6.5.4

Elasticsearch: 6.5.4 & kibana 6.5.4

JVM 1.8-131 Centos 7

Hello, i just installed search guard with the corresponding kibana plugin and i found out that i have to authenticate myself two times before i get to kibana.

  1. First when i go to https://127.0.0.1:443 (we have a nginx reverse proxy before kibana) i get a standard http authentication popup where i have to enter username and password

  2. Then i have to enter username and password again i the search guard login page

I want to only use the search guard login page, how and what should i change to achieve this?

You need to disable spaces in kibana.yml

    xpack.spaces.enabled: false

See https://docs.search-guard.com/latest/upgrading-560#kibana-spaces

···

Am 08.01.2019 um 15:40 schrieb Victor Nilsson <victornilsson2456@gmail.com>:

Searchguard: 6.5.4
Elasticsearch: 6.5.4 & kibana 6.5.4
JVM 1.8-131 Centos 7

Hello, i just installed search guard with the corresponding kibana plugin and i found out that i have to authenticate myself two times before i get to kibana.
1. First when i go to https://127.0.0.1:443 (we have a nginx reverse proxy before kibana) i get a standard http authentication popup where i have to enter username and password
2. Then i have to enter username and password again i the search guard login page

I want to only use the search guard login page, how and what should i change to achieve this?

--
You received this message because you are subscribed to the Google Groups "Search Guard Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/050730e1-d2f4-40bd-b0d0-1b936fc69632%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thank you.

···

On Tuesday, 8 January 2019 18:14:07 UTC+1, Search Guard wrote:

You need to disable spaces in kibana.yml

xpack.spaces.enabled: false

See https://docs.search-guard.com/latest/upgrading-560#kibana-spaces

Am 08.01.2019 um 15:40 schrieb Victor Nilsson victorni...@gmail.com:

Searchguard: 6.5.4

Elasticsearch: 6.5.4 & kibana 6.5.4

JVM 1.8-131 Centos 7

Hello, i just installed search guard with the corresponding kibana plugin and i found out that i have to authenticate myself two times before i get to kibana.

  1. First when i go to https://127.0.0.1:443 (we have a nginx reverse proxy before kibana) i get a standard http authentication popup where i have to enter username and password
  1. Then i have to enter username and password again i the search guard login page

I want to only use the search guard login page, how and what should i change to achieve this?


You received this message because you are subscribed to the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/050730e1-d2f4-40bd-b0d0-1b936fc69632%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.