[ELK 6.5.3 - SG 23.2] Issue when log in Kibana

Hi,

I have a new issue when i try to log in Kibana. It seems to be an basic auth. request.

Could you help me please ?

Thank you.

==[Configuration:]==

ELK_VERSION=6.5.3 (Basic Licence)

SG_VERSION=23.2

SG_VERSION_KIBANA=16

No Enterprise Module installed ths is the CE edition

Operting system : CENTOS 7x64 - SELinux=Permissive

OS[Linux/3.10.0-862.14.4.el7.x86_64/amd64],

JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/11.0.1/11.0.1+13]

==[Issue]==

Step 1) Screencopy 001:

From Search-Guard login screen, I fill-in my account: “admin”, password: “admin”

A new form appears to fill-in again my login and password, and i fill-in again with “admin/admin”

Then I log out.

Step 2) Screencopy 002

When disconnected, from Search-Guard login screen, I fill-in with another account: “readall”, and password: “readall”

Step 3) Screencopy 003

Then after the step 2) above, I am logged in Kibana, but with the user filled-in step 1) which is “admin” and not the one filled-in step 2) which is “readall”.

Do you have any idea to where can be the issue ?

Thank you for your support.

sg_action_groups.yml (2.31 KB)

sg_config.yml (9.4 KB)

sg_internal_users.yml (1.05 KB)

sg_roles.yml (6.9 KB)

sg_roles_mapping.yml (548 Bytes)

ELASTIC_Dockerfile (550 Bytes)

KIBANA_Dockerfile (460 Bytes)

LOGSTASH_Dockerfile (218 Bytes)

elasticsearch.yml (1.01 KB)

kibana.yml (545 Bytes)

logstash.yml (36 Bytes)

Did you disable spaces? If not you have to (at the moment).


Next Kibana Plugin release will indeed support spaces, its expected to be released next week.

···

Am 15.12.2018 um 09:31 schrieb plaz300664@gmail.com:

==[Configuration:]==
ELK_VERSION=6.5.3 (Basic Licence)
SG_VERSION=23.2
SG_VERSION_KIBANA=16

No Enterprise Module installed ths is the CE edition
Operting system : CENTOS 7x64 - SELinux=Permissive

OS[Linux/3.10.0-862.14.4.el7.x86_64/amd64],
JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/11.0.1/11.0.1+13]

==[Issue]==

Step 1) Screencopy 001:
From Search-Guard login screen, I fill-in my account: "admin", password: "admin"
A new form appears to fill-in again my login and password, and i fill-in again with "admin/admin"
Then I log out.

Step 2) Screencopy 002
When disconnected, from Search-Guard login screen, I fill-in with another account: "readall", and password: "readall"

Step 3) Screencopy 003
Then after the step 2) above, I am logged in Kibana, but with the user filled-in step 1) which is "admin" and not the one filled-in step 2) which is "readall".

Do you have any idea to where can be the issue ?

Thank you for your support.

--
You received this message because you are subscribed to the Google Groups "Search Guard Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/e5c0b1aa-3a01-4ee6-8da6-e75af2dcecc2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
<sg_action_groups.yml><sg_config.yml><sg_internal_users.yml><sg_roles.yml><sg_roles_mapping.yml><screencopy_001.png><ecreencopy_002.png><screencopy_003.png><ELASTIC_Dockerfile><KIBANA_Dockerfile><LOGSTASH_Dockerfile><elasticsearch.yml><kibana.yml><logstash.yml>

Hello,

Thank you for your reply. I think that i also tested it but to be honest I am not 100% sure.

In the meantime I reverted to the version 6.4.3. I will try again and come back to you asap.

Thank you !

···

Le samedi 15 décembre 2018 15:26:04 UTC+1, Search Guard a écrit :

Did you disable spaces? If not you have to (at the moment).

https://docs.search-guard.com/latest/upgrading-560#kibana-spaces

https://docs.search-guard.com/latest/kibana-plugin-installation#installing-the-search-guard-kibana-plugin

Next Kibana Plugin release will indeed support spaces, its expected to be released next week.

Am 15.12.2018 um 09:31 schrieb plaz3...@gmail.com:

==[Configuration:]==

ELK_VERSION=6.5.3 (Basic Licence)

SG_VERSION=23.2

SG_VERSION_KIBANA=16

No Enterprise Module installed ths is the CE edition

Operting system : CENTOS 7x64 - SELinux=Permissive

OS[Linux/3.10.0-862.14.4.el7.x86_64/amd64],
JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/11.0.1/11.0.1+13]

==[Issue]==

Step 1) Screencopy 001:

From Search-Guard login screen, I fill-in my account: “admin”, password: “admin”

A new form appears to fill-in again my login and password, and i fill-in again with “admin/admin”

Then I log out.

Step 2) Screencopy 002

When disconnected, from Search-Guard login screen, I fill-in with another account: “readall”, and password: “readall”

Step 3) Screencopy 003

Then after the step 2) above, I am logged in Kibana, but with the user filled-in step 1) which is “admin” and not the one filled-in step 2) which is “readall”.

Do you have any idea to where can be the issue ?

Thank you for your support.


You received this message because you are subscribed to the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/e5c0b1aa-3a01-4ee6-8da6-e75af2dcecc2%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

<sg_action_groups.yml><sg_config.yml><sg_internal_users.yml><sg_roles.yml><sg_roles_mapping.yml><screencopy_001.png><ecreencopy_002.png><screencopy_003.png><ELASTIC_Dockerfile><KIBANA_Dockerfile><LOGSTASH_Dockerfile><elasticsearch.yml><kibana.yml><logstash.yml>

I had the same issue with 6.5.4, and it turns out I managed to revert to a Kibana config without spaces disabled.

As per the fix above, add

xpack.spaces.enabled: false

to your kibana.yml

···

On Tuesday, 18 December 2018 03:32:05 UTC+13, plaz3...@gmail.com wrote:

Hello,

Thank you for your reply. I think that i also tested it but to be honest I am not 100% sure.

In the meantime I reverted to the version 6.4.3. I will try again and come back to you asap.

Thank you !

Le samedi 15 décembre 2018 15:26:04 UTC+1, Search Guard a écrit :

Did you disable spaces? If not you have to (at the moment).

https://docs.search-guard.com/latest/upgrading-560#kibana-spaces

https://docs.search-guard.com/latest/kibana-plugin-installation#installing-the-search-guard-kibana-plugin

Next Kibana Plugin release will indeed support spaces, its expected to be released next week.

Am 15.12.2018 um 09:31 schrieb plaz3...@gmail.com:

==[Configuration:]==

ELK_VERSION=6.5.3 (Basic Licence)

SG_VERSION=23.2

SG_VERSION_KIBANA=16

No Enterprise Module installed ths is the CE edition

Operting system : CENTOS 7x64 - SELinux=Permissive

OS[Linux/3.10.0-862.14.4.el7.x86_64/amd64],
JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/11.0.1/11.0.1+13]

==[Issue]==

Step 1) Screencopy 001:

From Search-Guard login screen, I fill-in my account: “admin”, password: “admin”

A new form appears to fill-in again my login and password, and i fill-in again with “admin/admin”

Then I log out.

Step 2) Screencopy 002

When disconnected, from Search-Guard login screen, I fill-in with another account: “readall”, and password: “readall”

Step 3) Screencopy 003

Then after the step 2) above, I am logged in Kibana, but with the user filled-in step 1) which is “admin” and not the one filled-in step 2) which is “readall”.

Do you have any idea to where can be the issue ?

Thank you for your support.


You received this message because you are subscribed to the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/e5c0b1aa-3a01-4ee6-8da6-e75af2dcecc2%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

<sg_action_groups.yml><sg_config.yml><sg_internal_users.yml><sg_roles.yml><sg_roles_mapping.yml><screencopy_001.png><ecreencopy_002.png><screencopy_003.png><ELASTIC_Dockerfile><KIBANA_Dockerfile><LOGSTASH_Dockerfile><elasticsearch.yml><kibana.yml><logstash.yml>

Hi CK,

Thank you for the info. I just tried with the latest release of ELK 6.5.4 SG 24.0 and Kibana 17 and i confirm that everything work fine.

Thank you for your support.

···

Le vendredi 21 décembre 2018 01:13:46 UTC+1, CK a écrit :

I had the same issue with 6.5.4, and it turns out I managed to revert to a Kibana config without spaces disabled.

As per the fix above, add

xpack.spaces.enabled: false

to your kibana.yml

On Tuesday, 18 December 2018 03:32:05 UTC+13, plaz3...@gmail.com wrote:

Hello,

Thank you for your reply. I think that i also tested it but to be honest I am not 100% sure.

In the meantime I reverted to the version 6.4.3. I will try again and come back to you asap.

Thank you !

Le samedi 15 décembre 2018 15:26:04 UTC+1, Search Guard a écrit :

Did you disable spaces? If not you have to (at the moment).

https://docs.search-guard.com/latest/upgrading-560#kibana-spaces

https://docs.search-guard.com/latest/kibana-plugin-installation#installing-the-search-guard-kibana-plugin

Next Kibana Plugin release will indeed support spaces, its expected to be released next week.

Am 15.12.2018 um 09:31 schrieb plaz3...@gmail.com:

==[Configuration:]==

ELK_VERSION=6.5.3 (Basic Licence)

SG_VERSION=23.2

SG_VERSION_KIBANA=16

No Enterprise Module installed ths is the CE edition

Operting system : CENTOS 7x64 - SELinux=Permissive

OS[Linux/3.10.0-862.14.4.el7.x86_64/amd64],
JVM[Oracle Corporation/OpenJDK 64-Bit Server VM/11.0.1/11.0.1+13]

==[Issue]==

Step 1) Screencopy 001:

From Search-Guard login screen, I fill-in my account: “admin”, password: “admin”

A new form appears to fill-in again my login and password, and i fill-in again with “admin/admin”

Then I log out.

Step 2) Screencopy 002

When disconnected, from Search-Guard login screen, I fill-in with another account: “readall”, and password: “readall”

Step 3) Screencopy 003

Then after the step 2) above, I am logged in Kibana, but with the user filled-in step 1) which is “admin” and not the one filled-in step 2) which is “readall”.

Do you have any idea to where can be the issue ?

Thank you for your support.


You received this message because you are subscribed to the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/e5c0b1aa-3a01-4ee6-8da6-e75af2dcecc2%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

<sg_action_groups.yml><sg_config.yml><sg_internal_users.yml><sg_roles.yml><sg_roles_mapping.yml><screencopy_001.png><ecreencopy_002.png><screencopy_003.png><ELASTIC_Dockerfile><KIBANA_Dockerfile><LOGSTASH_Dockerfile><elasticsearch.yml><kibana.yml><logstash.yml>