"document missing" error when creating new tenant

Env

  • Search Guard and Elasticsearch version: search-guard-5 5.3.2-12

  • Installed and used enterprise modules: kerberos

  • JVM version and operating system version: CentOS 7.3, openjdk-1.8.0.151-1.b12.el7_4

Error message

When creating the first time the kibana index of a new tenant ‘foo’, the index is created as ‘.kibana_-1429363305_foo’.
When kibana tries to set it as the default index (either just after creation, or through manual clicking of the star), I get the following error:
Config: Error 404 Not Found: [document_missing_exception] [config][5.3.2]: document missing, with { indexuuid="-3WdjLVzQpSfHPyU-lRbaw" & shard=“0” & index=".kibana-1429363305_foo" }

Note the difference in index name between the dash and the underscore.

The only workaround I found, was to copy another existing kibana index to ‘.kibana_-1429363305_foo’ and then to delete all visualizations/searches/index patterns from that.

Which version of the multitenancy module you have installed?

···

On Tuesday, 5 December 2017 09:39:55 UTC+1, Fabien Wernli wrote:

Env

  • Search Guard and Elasticsearch version: search-guard-5 5.3.2-12
  • Installed and used enterprise modules: kerberos
  • JVM version and operating system version: CentOS 7.3, openjdk-1.8.0.151-1.b12.el7_4

Error message

When creating the first time the kibana index of a new tenant ‘foo’, the index is created as ‘.kibana_-1429363305_foo’.
When kibana tries to set it as the default index (either just after creation, or through manual clicking of the star), I get the following error:
Config: Error 404 Not Found: [document_missing_exception] [config][5.3.2]: document missing, with { indexuuid="-3WdjLVzQpSfHPyU-lRbaw" & shard=“0” & index=".kibana-1429363305_foo" }

Note the difference in index name between the dash and the underscore.

sorry for failing to include that vital information!

#/usr/share/kibana/bin/kibana-plugin list
searchguard@5.3.2

I guess this doesn’t give you the revision.
Which file should I look at to be sure?

searchguard]$ find lib -type f | xargs md5sum
509b606ba947b3304dc780c8a54c06c3 lib/backend/searchguard.js
aa47156df6caf352fb0262be68135e2e lib/backend/filter_auth_headers.js
be9f159d4401fca54b8d54b04d060f14 lib/backend/searchguard_plugin.js
b1f0952517d5744905e2fb0f022a5946 lib/.DS_Store
f515536d814ac48befaa9aa6e78c092a lib/multitenancy/routes.js
7b6cd827e842c0c5511df6d52c5d53ad lib/multitenancy/headers.js
2e610bcbd812a4417e7a26f42b83cac9 lib/session/validate.js
81c4bfadffb70391f6853586303cd3c9 lib/session/invalid_session_error.js
5260ed76aee18c7c110300846b16591d lib/jwt/headers.js
b678ae10f097b777a1ee311004e57147 lib/hapi/auth.js
243e295d083d40e89636c7f34917489a lib/auth/user.js
9406d598cdeda81e9d17d95cc4816291 lib/auth/authentication_error.js
4239ce3fbd1aeaa19fc2fa13904c849b lib/auth/routes_authinfo.js
5ce7ce8a2ffb4ee22049644e86d4936e lib/auth/routes.js

``

any idea on what could be wrong?

Hi - I tried to reproduce this behavior in a number of ways, but unfortunately could not.

I used:

KI / ES 5.3.2

SG 5.3.2-12

Multi Tenancy 5.3-4 (latest one)

Kibana Plugin 5.3.2-3

My steps:

  • I start with an empty data directory and empty browser, i.e. no cookies, local storage etc.

  • I create the SG index and put in some sample data in 2 indices.

  • Log in to Kibana, select a tenant

  • Create an index pattern, it’s set as default pattern automatically

  • Create another index pattern

  • Switch between the patterns by clicking on the star

Everything works as expected, no error thrown. So, are these steps valid to reproduce your issue or do I need to do something in addition? Also, do you use the global tenant or is it disabled?

Can you also check that you used the latest version of the Kibana Multi Tenancy module by checking the respective jar file in the plugins/search-guard-5 folder?

Thanks!

···

On Thursday, December 7, 2017 at 3:15:02 PM UTC+1, Fabien Wernli wrote:

any idea on what could be wrong?