Crash on new Kibana beta plugin

If you think it is a bug report or you have a technical issue, please answer the following questions. For general questions, you can delete these questions.

Elasticsearch version:
7.9.1
Server OS version:
Ubuntu 18.04 LTS
Kibana version (if relevant):
7.9.1
Describe the issue:
New beta plugin for Kibana 7.9.1 crashes during startup.
Steps to reproduce:
1.Remove standard Searchguard plugin from KIbana
2.Install beta plugin and make required patch
3.Start KIbana. Web site never comes as Kibana crashes and restarts repeatedly during plugin initialistion.

Expected behavior:
Web server should become usable after initialisation

Configurations and logs are in attached TAR.GZ. I ran Kibana with logging set to verbose.

Regards

Max

Thank you for trying the New Platform beta. I don’t see the attachment. You can send it to me in a private message.

Hi, @maxcaines.
I received your archive. But I saw no error in the Kibana log. The log window is too short, less than 1 minute. Probably the error was there but you didn’t copy the full log.

I’ve built the beta with the latest code for you. Can you try it? https://drive.google.com/drive/folders/1E6jsw1_XR9nzd0I1p-iahBPpdU1xfyHg?usp=sharing

Hi Sergii

There isn’t an error message. The process just dies. You should see that the PID numbers on the log messages change regularly, because the initialisation gets so far and then the process crashes. The Linux Systemctl process then starts a replacement, which begins the who cycle again

Regards

Max

Is it the same with the plugin I built for you today? Btw no patch it needed for this one.

Hi Sergii

Yes, exactly the same, I’m afraid

Max