Sg-elasticsearch Dockerfile configuration for vm

When running docker-hub image floragunncom/sg-elasticsearch:7.1.1-35.0.0

on a local computer everything appears fine, when running on an openshift cluster give VM memory error related with vm.max_map_count=262144. Would it be possible to get the Dockerfile itself where I can set this and run it over instead of the image or where can I find the code of this ?

Sure, see https://github.com/floragunncom/search-guard-helm/tree/master/docker and https://github.com/elastic/elasticsearch/tree/7.1/distribution/docker

You may also have a look here https://www.elastic.co/guide/en/elasticsearch/reference/current/vm-max-map-count.html and https://discuss.elastic.co/t/setting-up-elasticsearch-on-a-virtual-machine/108849

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.