search guard rest api return "No ssl info found"

I get “No ssl info found” when use api “get _searchguard/api/user”
The elasticsearch.yaml is :

searchguard.ssl.transport.keystore_filepath: kirk-keystore.jks
searchguard.ssl.transport.keystore_password: changeit
searchguard.ssl.transport.truststore_filepath: truststore.jks
searchguard.ssl.transport.truststore_password: changeit
searchguard.ssl.transport.enforce_hostname_verification: false
searchguard.ssl.transport.enable_openssl_if_available: true
searchguard.ssl.http.enabled: false
searchguard.ssl.http.keystore_filepath: kirk-keystore.jks
searchguard.ssl.http.keystore_password: changeit
searchguard.ssl.http.truststore_filepath: truststore.jks
searchguard.ssl.http.truststore_password: changeit
searchguard.authcz.admin_dn:

  • CN=kirk, OU=client, O=client, L=Test, C=DE

``

Hi,
you have already highlighted the configuration which needs to be changed:
You need to set searchguard.ssl.http.enabled: trueIf it is set to false no certificate will be provided whatsoever.
Once you have changed this, you only need to make sure you are providing the right certificate to enable authentication.

Since I can not see from your snippet how you are sending your request - curl, wget, browser, etc. please see our documentation for details on either of the methods:
http://floragunncom.github.io/search-guard-docs/ and for details especially about different certificate types, see http://floragunncom.github.io/search-guard-docs/tls_certificates_production.html.

Thanks for your question, I hope this answer helps,
regards, Urs.


-- Urs Armbruster
Community Manager
floragunn GmbH
Tempelhofer Ufer 16
10963 Berlin
Amtsgericht Charlottenburg HRB 147010
USt-IdNr.: DE287373363
+++ like us on facebook: [https://www.facebook.com/searchguard](https://www.facebook.com/searchguard)
+++ follow us on twitter: [https://twitter.com/searchguard](https://twitter.com/searchguard)
···

On Monday, August 21, 2017 at 3:13:52 AM UTC+2, Hubiao Lou wrote:

I get “No ssl info found” when use api “get _searchguard/api/user”
The elasticsearch.yaml is :

searchguard.ssl.transport.keystore_filepath: kirk-keystore.jks
searchguard.ssl.transport.keystore_password: changeit
searchguard.ssl.transport.truststore_filepath: truststore.jks
searchguard.ssl.transport.truststore_password: changeit
searchguard.ssl.transport.enforce_hostname_verification: false
searchguard.ssl.transport.enable_openssl_if_available: true
searchguard.ssl.http.enabled: false
searchguard.ssl.http.keystore_filepath: kirk-keystore.jks
searchguard.ssl.http.keystore_password: changeit
searchguard.ssl.http.truststore_filepath: truststore.jks
searchguard.ssl.http.truststore_password: changeit
searchguard.authcz.admin_dn:

  • CN=kirk, OU=client, O=client, L=Test, C=DE

``