Problem using Kibana with Search Guard Bundle 5.0.0-8

Hi all,

I installed the Search Guard Bundle 5.0.0-8 and Kibana following the provided instructions. The Problem I am currently facing is, that I am not able to use the Kibana Dev Tools (e.G. http://127.0.0.1:5601/app/kibana#/dev_tools/) : I am getting the error :

Error connecting to ‘https://localhost:9200/_search’:

Client request error: self signed certificate in certificate chain"

Any Idea what could be missing? I already the validity check for SSL certs in the kibana.yml using

“elasticsearch.ssl.verify: false”

Any help is really appreciated!

Thanks in advance

Horst

Hi Horst,

thanks for reporting this, we can reproduce it, but it seems more like a bug in Kibana. Setting ssl.verify to false should also apply to the dev tools. We will have a look, but there’s probably not much we can do.

···

On Friday, 18 November 2016 15:21:44 UTC+1, Horst Hacker wrote:

Hi all,

I installed the Search Guard Bundle 5.0.0-8 and Kibana following the provided instructions. The Problem I am currently facing is, that I am not able to use the Kibana Dev Tools (e.G. http://127.0.0.1:5601/app/kibana#/dev_tools/) : I am getting the error :

Error connecting to ‘https://localhost:9200/_search’:

Client request error: self signed certificate in certificate chain"

Any Idea what could be missing? I already the validity check for SSL certs in the kibana.yml using

“elasticsearch.ssl.verify: false”

Any help is really appreciated!

Thanks in advance

Horst

Ok, found something. Seems you need to configure SSL separate for the console. Can you try to add the following snippet to your Kibana configuration and let us know if it helpded?

console.proxyConfig:

  • match:

protocol: “https”

ssl:

verify: false # allows any certificate to be used, even self-signed certs

See also here:

https://www.elastic.co/guide/en/sense/current/installing.html

···

On Friday, 25 November 2016 16:49:36 UTC+1, Search Guard wrote:

Hi Horst,

thanks for reporting this, we can reproduce it, but it seems more like a bug in Kibana. Setting ssl.verify to false should also apply to the dev tools. We will have a look, but there’s probably not much we can do.

On Friday, 18 November 2016 15:21:44 UTC+1, Horst Hacker wrote:

Hi all,

I installed the Search Guard Bundle 5.0.0-8 and Kibana following the provided instructions. The Problem I am currently facing is, that I am not able to use the Kibana Dev Tools (e.G. http://127.0.0.1:5601/app/kibana#/dev_tools/) : I am getting the error :

Error connecting to ‘https://localhost:9200/_search’:

Client request error: self signed certificate in certificate chain"

Any Idea what could be missing? I already the validity check for SSL certs in the kibana.yml using

“elasticsearch.ssl.verify: false”

Any help is really appreciated!

Thanks in advance

Horst

Hi,

thank you very much for coming back on this.

This is actually the solution I also came up with. So I can confirm that
this is working. Sorry for not writing this to the forum immediately. I
found it Friday evening and thought Monday would be soon enough :wink:

At least it can now be found if somebody else is facing this problem.

Once again thank you!