Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

Hi Folks, I’m attempting to run Search Guard with Elastic Search on Windows. I’ve gone and installed it as normal and configured the yml files as required.
When starting up Elastic Search 2.1, I’m getting the following error, I don’t have tomcat installed anyway on my development machine…

Can anyone suggest what I may have done incorrectly, or a potential work around of the problem.

Kind Regards

Noel

Logs Below:

[2016-02-02 16:26:18,048][WARN ][bootstrap ] unable to install syscall filter: syscall filtering not supported for OS: ‘Windows 7’

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] version[2.1.0], pid[18976], build[72cd1f1/2015-11-18T22:40:03Z]

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] initializing …

[2016-02-02 16:26:18,583][INFO ][plugins ] [Kurse] loaded [search-guard-ssl], sites

[2016-02-02 16:26:18,635][INFO ][env ] [Kurse] using [1] data paths, mounts [[OS (C:)]], net usable_space [250.1gb], net total_space [450gb], spins? [unknown], types [NTFS]

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

this is not an error (its just saying that openssl is not available so it fall back to the java ssl implementation). If you want use open ssl look here: https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

···

Am Dienstag, 2. Februar 2016 17:35:20 UTC+1 schrieb Noel Lysaght:

Hi Folks, I’m attempting to run Search Guard with Elastic Search on Windows. I’ve gone and installed it as normal and configured the yml files as required.
When starting up Elastic Search 2.1, I’m getting the following error, I don’t have tomcat installed anyway on my development machine…

Can anyone suggest what I may have done incorrectly, or a potential work around of the problem.

Kind Regards

Noel

Logs Below:

[2016-02-02 16:26:18,048][WARN ][bootstrap ] unable to install syscall filter: syscall filtering not supported for OS: ‘Windows 7’

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] version[2.1.0], pid[18976], build[72cd1f1/2015-11-18T22:40:03Z]

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] initializing …

[2016-02-02 16:26:18,583][INFO ][plugins ] [Kurse] loaded [search-guard-ssl], sites

[2016-02-02 16:26:18,635][INFO ][env ] [Kurse] using [1] data paths, mounts [[OS (C:)]], net usable_space [250.1gb], net total_space [450gb], spins? [unknown], types [NTFS]

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

this link is not available…could u tell me the new?

https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

在 2016年2月3日星期三 UTC+8上午1:53:14,Search Guard写道:

···

this is not an error (its just saying that openssl is not available so it fall back to the java ssl implementation). If you want use open ssl look here: https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

Am Dienstag, 2. Februar 2016 17:35:20 UTC+1 schrieb Noel Lysaght:

Hi Folks, I’m attempting to run Search Guard with Elastic Search on Windows. I’ve gone and installed it as normal and configured the yml files as required.
When starting up Elastic Search 2.1, I’m getting the following error, I don’t have tomcat installed anyway on my development machine…

Can anyone suggest what I may have done incorrectly, or a potential work around of the problem.

Kind Regards

Noel

Logs Below:

[2016-02-02 16:26:18,048][WARN ][bootstrap ] unable to install syscall filter: syscall filtering not supported for OS: ‘Windows 7’

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] version[2.1.0], pid[18976], build[72cd1f1/2015-11-18T22:40:03Z]

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] initializing …

[2016-02-02 16:26:18,583][INFO ][plugins ] [Kurse] loaded [search-guard-ssl], sites

[2016-02-02 16:26:18,635][INFO ][env ] [Kurse] using [1] data paths, mounts [[OS (C:)]], net usable_space [250.1gb], net total_space [450gb], spins? [unknown], types [NTFS]

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

The OpenSSL setup is documented in the official docs here:

···

On Monday, June 25, 2018 at 1:15:08 PM UTC+2, 775878550@qq.com wrote:

this link is not available…could u tell me the new?

https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

在 2016年2月3日星期三 UTC+8上午1:53:14,Search Guard写道:

this is not an error (its just saying that openssl is not available so it fall back to the java ssl implementation). If you want use open ssl look here: https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

Am Dienstag, 2. Februar 2016 17:35:20 UTC+1 schrieb Noel Lysaght:

Hi Folks, I’m attempting to run Search Guard with Elastic Search on Windows. I’ve gone and installed it as normal and configured the yml files as required.
When starting up Elastic Search 2.1, I’m getting the following error, I don’t have tomcat installed anyway on my development machine…

Can anyone suggest what I may have done incorrectly, or a potential work around of the problem.

Kind Regards

Noel

Logs Below:

[2016-02-02 16:26:18,048][WARN ][bootstrap ] unable to install syscall filter: syscall filtering not supported for OS: ‘Windows 7’

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] version[2.1.0], pid[18976], build[72cd1f1/2015-11-18T22:40:03Z]

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] initializing …

[2016-02-02 16:26:18,583][INFO ][plugins ] [Kurse] loaded [search-guard-ssl], sites

[2016-02-02 16:26:18,635][INFO ][env ] [Kurse] using [1] data paths, mounts [[OS (C:)]], net usable_space [250.1gb], net total_space [450gb], spins? [unknown], types [NTFS]

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

thans for your reply! I set up openssl accourding to this document and openssl is avaliable. But I meet another problem. when I send request with certificates, the commond line shows “Peer reports it experienced an internal error.”
the elasticsearch log is as follows:
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

···

775878550@qq.com

From: Jochen Kressin

Date: 2018-06-25 22:43

To: Search Guard Community Forum

Subject: [search-guard group] Re: Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

The OpenSSL setup is documented in the official docs here:

https://docs.search-guard.com/latest/openssl

On Monday, June 25, 2018 at 1:15:08 PM UTC+2, 775878550@qq.com wrote:

this link is not available…could u tell me the new?

https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

在 2016年2月3日星期三 UTC+8上午1:53:14,Search Guard写道:

this is not an error (its just saying that openssl is not available so it fall back to the java ssl implementation). If you want use open ssl look here: https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

Am Dienstag, 2. Februar 2016 17:35:20 UTC+1 schrieb Noel Lysaght:

Hi Folks, I’m attempting to run Search Guard with Elastic Search on Windows. I’ve gone and installed it as normal and configured the yml files as required.
When starting up Elastic Search 2.1, I’m getting the following error, I don’t have tomcat installed anyway on my development machine…

Can anyone suggest what I may have done incorrectly, or a potential work around of the problem.

Kind Regards

Noel

Logs Below:

[2016-02-02 16:26:18,048][WARN ][bootstrap ] unable to install syscall filter: syscall filtering not supported for OS: ‘Windows 7’

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] version[2.1.0], pid[18976], build[72cd1f1/2015-11-18T22:40:03Z]

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] initializing …

[2016-02-02 16:26:18,583][INFO ][plugins ] [Kurse] loaded [search-guard-ssl], sites

[2016-02-02 16:26:18,635][INFO ][env ] [Kurse] using [1] data paths, mounts [[OS (C:)]], net usable_space [250.1gb], net total_space [450gb], spins? [unknown], types [NTFS]

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

You received this message because you are subscribed to a topic in the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/search-guard/SgnEni10IPs/unsubscribe.

To unsubscribe from this group and all its topics, send an email to search-guard+unsubscribe@googlegroups.com.

To post to this group, send email to search-guard@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/a8015068-61f0-40ef-84bc-70a5e9774331%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

This line here:

Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

``

Usually indicates that a certificate was returned during the handshake that is not trusted. Means, the certificate cannot be validated against the root CA you configured. Please check that the configured root CA PEM is the one used to sign the certificates you sent, or, if you use JKS, that the root CA is present in your configured truststore.

···

On Tuesday, June 26, 2018 at 3:00:42 AM UTC+2, 775878550@qq.com wrote:

thans for your reply! I set up openssl accourding to this document and openssl is avaliable. But I meet another problem. when I send request with certificates, the commond line shows “Peer reports it experienced an internal error.”
the elasticsearch log is as follows:
Caused by: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target


775878550@qq.com

From: Jochen Kressin

Date: 2018-06-25 22:43

To: Search Guard Community Forum

Subject: [search-guard group] Re: Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

The OpenSSL setup is documented in the official docs here:

https://docs.search-guard.com/latest/openssl

On Monday, June 25, 2018 at 1:15:08 PM UTC+2, 775878550@qq.com wrote:

this link is not available…could u tell me the new?

https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

在 2016年2月3日星期三 UTC+8上午1:53:14,Search Guard写道:

this is not an error (its just saying that openssl is not available so it fall back to the java ssl implementation). If you want use open ssl look here: https://github.com/floragunncom/search-guard-ssl/wiki/Open-SSL-setup

Am Dienstag, 2. Februar 2016 17:35:20 UTC+1 schrieb Noel Lysaght:

Hi Folks, I’m attempting to run Search Guard with Elastic Search on Windows. I’ve gone and installed it as normal and configured the yml files as required.
When starting up Elastic Search 2.1, I’m getting the following error, I don’t have tomcat installed anyway on my development machine…

Can anyone suggest what I may have done incorrectly, or a potential work around of the problem.

Kind Regards

Noel

Logs Below:

[2016-02-02 16:26:18,048][WARN ][bootstrap ] unable to install syscall filter: syscall filtering not supported for OS: ‘Windows 7’

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] version[2.1.0], pid[18976], build[72cd1f1/2015-11-18T22:40:03Z]

[2016-02-02 16:26:18,198][INFO ][node ] [Kurse] initializing …

[2016-02-02 16:26:18,583][INFO ][plugins ] [Kurse] loaded [search-guard-ssl], sites

[2016-02-02 16:26:18,635][INFO ][env ] [Kurse] using [1] data paths, mounts [[OS (C:)]], net usable_space [250.1gb], net total_space [450gb], spins? [unknown], types [NTFS]

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

[2016-02-02 16:26:18,735][INFO ][com.floragunn.searchguard.ssl.SearchGuardKeyStore] Open SSL not available because of java.lang.ClassNotFoundException: org.apache.tomcat.jni.SSL

You received this message because you are subscribed to a topic in the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this topic, visit https://groups.google.com/d/topic/search-guard/SgnEni10IPs/unsubscribe.

To unsubscribe from this group and all its topics, send an email to search-guard+unsubscribe@googlegroups.com.

To post to this group, send email to search-guard@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/a8015068-61f0-40ef-84bc-70a5e9774331%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.