None of the configured nodes are available

Hello everyone i tried to use search guard using the example.sh to generate keystore and certificates, but when i try to initialize sgadmin i get this message

./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd …/sgconfig -cn nodo -nhnv
Search Guard Admin v5
Will connect to localhost:9300 … done
Contacting elasticsearch cluster ‘nodo’ and wait for YELLOW clusterstate …
Cannot retrieve cluster state due to: None of the configured nodes are available: [{#transport#-1}{aZaCLBM1TG693peAfvIEdw}{localhost}{127.0.0.1:9300}]. This is not an error, will keep on trying …

  • Try running sgadmin.sh with -icl and -nhnv (If thats works you need to check your clustername as well as hostnames in your SSL certificates)
  • If this is not working, try running sgadmin.sh with --diagnose and see diagnose trace log file)

i already try with -icl parameter the same result. i attach elasticsearch.yml and diagnostic log from sgadmin and also elastic log (nodo.log).

any idea… thanks a lot in advantage

sgadmin_diag_trace_2017-Mar-16_20-04-50.txt (13.3 KB)

sgadmin_diag_trace_2017-Mar-16_20-06-39.txt (13.3 KB)

elasticsearch.yml (4.55 KB)

nodo.log (26.4 KB)

This commands loo correct
./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd ../sgconfig -cn nodo -nhnv
./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd ../sgconfig -icl -nhnv

but there are a few other thing which are strange:

1) Pls run elasticsearch as well as sgadmin with java 8 and not java 9 which ist not released and not supported yet
2) network.host: [192.168.3.113,127.0.0.1] in elasticsearch.yml makes no sense, this should be a single hostname/ip and not an array (and even then it had to look like ["192.168.3.113","127.0.0.1"] )
3) The diagnose trace show that you executed sgadmin like that: "-ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd ../sgconfig -cn icl -nhnv --diagnose" which is indeed wrong

You can also try our bundle https://github.com/floragunncom/search-guard/wiki/Search-Guard-Bundle

···

Am 23.03.2017 um 21:02 schrieb Maikel Ortega Hernández <maikeloh@gmail.com>:

Hello everyone i tried to use search guard using the example.sh to generate keystore and certificates, but when i try to initialize sgadmin i get this message

./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd ../sgconfig -cn nodo -nhnv
Search Guard Admin v5
Will connect to localhost:9300 ... done
Contacting elasticsearch cluster 'nodo' and wait for YELLOW clusterstate ...
Cannot retrieve cluster state due to: None of the configured nodes are available: [{#transport#-1}{aZaCLBM1TG693peAfvIEdw}{localhost}{127.0.0.1:9300}]. This is not an error, will keep on trying ...
   * Try running sgadmin.sh with -icl and -nhnv (If thats works you need to check your clustername as well as hostnames in your SSL certificates)
   * If this is not working, try running sgadmin.sh with --diagnose and see diagnose trace log file)

i already try with -icl parameter the same result. i attach elasticsearch.yml and diagnostic log from sgadmin and also elastic log (nodo.log).

any idea.. thanks a lot in advantage

--
You received this message because you are subscribed to the Google Groups "Search Guard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/61b13fd5-1b7a-4cfe-81e3-b305e228f434%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
<sgadmin_diag_trace_2017-Mar-16_20-04-50.txt><sgadmin_diag_trace_2017-Mar-16_20-06-39.txt><elasticsearch.yml><nodo.log>

java 9 was that cause the error, thanks a lot for the answer

···

El jueves, 23 de marzo de 2017, 15:41:07 (UTC-5), Search Guard escribió:

This commands loo correct

./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd …/sgconfig -cn nodo -nhnv

./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd …/sgconfig -icl -nhnv

but there are a few other thing which are strange:

  1. Pls run elasticsearch as well as sgadmin with java 8 and not java 9 which ist not released and not supported yet

  2. network.host: [192.168.3.113,127.0.0.1] in elasticsearch.yml makes no sense, this should be a single hostname/ip and not an array (and even then it had to look like [“192.168.3.113”,“127.0.0.1”] )

  3. The diagnose trace show that you executed sgadmin like that: “-ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd …/sgconfig -cn icl -nhnv --diagnose” which is indeed wrong

You can also try our bundle https://github.com/floragunncom/search-guard/wiki/Search-Guard-Bundle

Am 23.03.2017 um 21:02 schrieb Maikel Ortega Hernández maik...@gmail.com:

Hello everyone i tried to use search guard using the example.sh to generate keystore and certificates, but when i try to initialize sgadmin i get this message

./sgadmin.sh -ts truststore.jks -tspass changeit -ks kirk-keystore.jks -kspass changeit -cd …/sgconfig -cn nodo -nhnv

Search Guard Admin v5

Will connect to localhost:9300 … done

Contacting elasticsearch cluster ‘nodo’ and wait for YELLOW clusterstate …

Cannot retrieve cluster state due to: None of the configured nodes are available: [{#transport#-1}{aZaCLBM1TG693peAfvIEdw}{localhost}{127.0.0.1:9300}]. This is not an error, will keep on trying …

  • Try running sgadmin.sh with -icl and -nhnv (If thats works you need to check your clustername as well as hostnames in your SSL certificates)
  • If this is not working, try running sgadmin.sh with --diagnose and see diagnose trace log file)

i already try with -icl parameter the same result. i attach elasticsearch.yml and diagnostic log from sgadmin and also elastic log (nodo.log).

any idea… thanks a lot in advantage


You received this message because you are subscribed to the Google Groups “Search Guard” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/61b13fd5-1b7a-4cfe-81e3-b305e228f434%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

<sgadmin_diag_trace_2017-Mar-16_20-04-50.txt><sgadmin_diag_trace_2017-Mar-16_20-06-39.txt><elasticsearch.yml><nodo.log>