No permissions for index delayed timeout

Hello,

ES : 7.5
SG : 7.5

I have a permission problem about delayed timeout settings.

When i try to put this settings, i have this error message : -X PUT “localhost:9290/_all/_settings?pretty” -H ‘Content-Type: application/json’ -d’ { “settings”: { “index.unassigned.node_left.delayed_timeout”: “5m” } } ’

“type” : “security_exception”,
“reason” : "no permissions for and User [name=admin_userldap

Where can I authorize this action?

Thanks for reply.

Best Regards.

If you don’t provide TLS certificates, a user you use is a regular user. Regular users can’t update settings. Just put the certificates in the call.

You are trying to change settings for all indices /_all/_settings. We don’t recommend changing settings for the Search Guard indices: searchguard and .signals*. Indicate a list of the indices in the call instead.

For example

curl -u admin:admin -X PUT \
https://localhost:9200/index0,index1,index2/_settings \
-H 'Content-Type: application/json' \
-d '{ "settings": { "index.unassigned.node_left.delayed_timeout": "5m" } }'  \
--cert elasticsearch-7.8.0/config/kirk.pem \
--key elasticsearch-7.8.0/config/kirk-key.pem \
--cacert elasticsearch-7.8.0/config/root-ca.pem

Result

{"acknowledged":true}

https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-update-settings.html

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.