Kibana4.1 error: Courier Fetch: Cannot read property 'timed_out' of undefined ( Search Guard)

My elasticsearch.yml is:

###################### search guard ########################

searchguard.allow_all_from_loopback: true

searchguard.authentication.settingsdb.user.root: biglog.org

searchguard.authentication.settingsdb.user.crazw: jia0926

searchguard.authentication.settingsdb.user.crazw3: jia0926

searchguard.authentication.authorization.settingsdb.roles.root: [“root”]

searchguard.authentication.authorization.settingsdb.roles.crazw: [“crazw”]

searchguard.authentication.authorization.settingsdb.roles.crazw3: [“doc”]

searchguard.dlsfilter.names: [“b”]

searchguard.dlsfilter.b: [“term”, “tags”,“file”, “true”]

My searchguard indices is :

curl -XPUT ‘http://localhost:9200/searchguard/ac/ac?pretty’ -d ’

{“acl”: [

{

“filters_bypass”: ,

“filters_execute”: ["*"]

},

{

“roles”: [“doc”],

“indices”: [“biglog-crazw-*”],

“filters_bypass”: ,

“filters_execute”: [“dlsfilter.*”]

},

{

“roles”: [“root”],

“indices”: ["*"],

“filters_bypass”: ["*"],

“filters_execute”:

}

]}’

But when I login with the root user to access kibana4.1 ,it show me that:

When I delete the conf of dlsfilter , it will be ok!

Can you give some suggets, What is wrong with my conf file?

Thank you so much!

can you post (or mail) debug logs?

···

Am Donnerstag, 4. Juni 2015 20:09:56 UTC+2 schrieb Crazw jia:

My elasticsearch.yml is:

###################### search guard ########################

searchguard.allow_all_from_loopback: true

searchguard.authentication.settingsdb.user.root: biglog.org

searchguard.authentication.settingsdb.user.crazw: jia0926

searchguard.authentication.settingsdb.user.crazw3: jia0926

searchguard.authentication.authorization.settingsdb.roles.root: [“root”]

searchguard.authentication.authorization.settingsdb.roles.crazw: [“crazw”]

searchguard.authentication.authorization.settingsdb.roles.crazw3: [“doc”]

searchguard.dlsfilter.names: [“b”]

searchguard.dlsfilter.b: [“term”, “tags”,“file”, “true”]

My searchguard indices is :

curl -XPUT ‘http://localhost:9200/searchguard/ac/ac?pretty’ -d ’

{“acl”: [

{

“filters_bypass”: ,

“filters_execute”: ["*"]

},

{

“roles”: [“doc”],

“indices”: [“biglog-crazw-*”],

“filters_bypass”: ,

“filters_execute”: [“dlsfilter.*”]

},

{

“roles”: [“root”],

“indices”: ["*"],

“filters_bypass”: ["*"],

“filters_execute”:

}

]}’

But when I login with the root user to access kibana4.1 ,it show me that:

When I delete the conf of dlsfilter , it will be ok!

Can you give some suggets, What is wrong with my conf file?

Thank you so much!

I’m getting the same error. But if i sign in with as ‘admin’ i get: “Courier Fetch: resp is undefined”. querying against elasticsearch directly seem to be working, and the filters work great so thanks :smiley:

Oops!

Looks like something went wrong. Refreshing may do the trick.

  or


clear your session

Fatal Error

Courier Fetch: resp is undefined

callResponseHandlers/<@http://127.0.0.1:9548/index.js?_b=5930:42957:1
Promise.try@http://127.0.0.1:9548/index.js?_b=5930:46205:23
Promise.map/<@http://127.0.0.1:9548/index.js?_b=5930:46183:16
Promise.map@http://127.0.0.1:9548/index.js?_b=5930:46182:26
callResponseHandlers@http://127.0.0.1:9548/index.js?_b=5930:42950:1
fetchWithStrategy/<@http://127.0.0.1:9548/index.js?_b=5930:43068:16
qFactory/defer/deferred.promise.then/wrappedCallback@http://127.0.0.1:9548/index.js?_b=5930:20873:31
qFactory/defer/deferred.promise.then/wrappedCallback@http://127.0.0.1:9548/index.js?_b=5930:20873:31
qFactory/ref/<.then/<@http://127.0.0.1:9548/index.js?_b=5930:20959:26
$RootScopeProvider/this.$get</Scope.prototype.$eval@http://127.0.0.1:9548/index.js?_b=5930:22002:16
$RootScopeProvider/this.$get</Scope.prototype.$digest@http://127.0.0.1:9548/index.js?_b=5930:21814:15
$RootScopeProvider/this.$get</Scope.prototype.$apply@http://127.0.0.1:9548/index.js?_b=5930:22106:13
done@http://127.0.0.1:9548/index.js?_b=5930:17641:34
completeRequest@http://127.0.0.1:9548/index.js?_b=5930:17855:7

createHttpBackend/</xhr.onreadystatechange@http://127.0.0.1:9548/index.js?_b=5930:17794:1

···

On Friday, June 5, 2015 at 4:35:04 PM UTC+8, in...@search-guard.com wrote:

can you post (or mail) debug logs?

Am Donnerstag, 4. Juni 2015 20:09:56 UTC+2 schrieb Crazw jia:

My elasticsearch.yml is:

###################### search guard ########################

searchguard.allow_all_from_loopback: true

searchguard.authentication.settingsdb.user.root: biglog.org

searchguard.authentication.settingsdb.user.crazw: jia0926

searchguard.authentication.settingsdb.user.crazw3: jia0926

searchguard.authentication.authorization.settingsdb.roles.root: [“root”]

searchguard.authentication.authorization.settingsdb.roles.crazw: [“crazw”]

searchguard.authentication.authorization.settingsdb.roles.crazw3: [“doc”]

searchguard.dlsfilter.names: [“b”]

searchguard.dlsfilter.b: [“term”, “tags”,“file”, “true”]

My searchguard indices is :

curl -XPUT ‘http://localhost:9200/searchguard/ac/ac?pretty’ -d ’

{“acl”: [

{

“filters_bypass”: ,

“filters_execute”: ["*"]

},

{

“roles”: [“doc”],

“indices”: [“biglog-crazw-*”],

“filters_bypass”: ,

“filters_execute”: [“dlsfilter.*”]

},

{

“roles”: [“root”],

“indices”: ["*"],

“filters_bypass”: ["*"],

“filters_execute”:

}

]}’

But when I login with the root user to access kibana4.1 ,it show me that:

When I delete the conf of dlsfilter , it will be ok!

Can you give some suggets, What is wrong with my conf file?

Thank you so much!

we will provide a guide, how to setup and configure search guard with kibana, soon

···

Am 05.06.2015 um 13:27 schrieb Lingxiao Xia <lingxiao.xia@dragonlaw.com.hk>:

I'm getting the same error. But if i sign in with as 'admin' i get: "Courier Fetch: resp is undefined". querying against elasticsearch directly seem to be working, and the filters work great so thanks :smiley:

'
Oops!

Looks like something went wrong. Refreshing may do the trick.

or clear your session

Fatal Error

Courier Fetch: resp is undefined
callResponseHandlers/<@http://127.0.0.1:9548/index.js?_b=5930:42957:1

Promise.try@
http://127.0.0.1:9548/index.js?_b=5930:46205:23

Promise.map/<@
http://127.0.0.1:9548/index.js?_b=5930:46183:16

Promise.map@
http://127.0.0.1:9548/index.js?_b=5930:46182:26

callResponseHandlers@
http://127.0.0.1:9548/index.js?_b=5930:42950:1

fetchWithStrategy/<@
http://127.0.0.1:9548/index.js?_b=5930:43068:16

qFactory/defer/deferred.promise.then/wrappedCallback@
http://127.0.0.1:9548/index.js?_b=5930:20873:31

qFactory/defer/deferred.promise.then/wrappedCallback@
http://127.0.0.1:9548/index.js?_b=5930:20873:31

qFactory/ref/<.then/<@
http://127.0.0.1:9548/index.js?_b=5930:20959:26

$RootScopeProvider/this.$get</Scope.prototype.$eval@
http://127.0.0.1:9548/index.js?_b=5930:22002:16

$RootScopeProvider/this.$get</Scope.prototype.$digest@
http://127.0.0.1:9548/index.js?_b=5930:21814:15

$RootScopeProvider/this.$get</Scope.prototype.$apply@
http://127.0.0.1:9548/index.js?_b=5930:22106:13

done@
http://127.0.0.1:9548/index.js?_b=5930:17641:34

completeRequest@
http://127.0.0.1:9548/index.js?_b=5930:17855:7
createHttpBackend/</xhr.onreadystatechange@http://127.0.0.1:9548/index.js?_b=5930:17794:1'

On Friday, June 5, 2015 at 4:35:04 PM UTC+8, in...@search-guard.com wrote:
can you post (or mail) debug logs?

Am Donnerstag, 4. Juni 2015 20:09:56 UTC+2 schrieb Crazw jia:
My elasticsearch.yml is:
###################### search guard ########################
searchguard.allow_all_from_loopback: true

searchguard.authentication.settingsdb.user.root: biglog.org
searchguard.authentication.settingsdb.user.crazw: jia0926
searchguard.authentication.settingsdb.user.crazw3: jia0926

searchguard.authentication.authorization.settingsdb.roles.root: ["root"]
searchguard.authentication.authorization.settingsdb.roles.crazw: ["crazw"]
searchguard.authentication.authorization.settingsdb.roles.crazw3: ["doc"]

searchguard.dlsfilter.names: ["b"]
searchguard.dlsfilter.b: ["term", "tags","file", "true"]

My searchguard indices is :
curl -XPUT 'http://localhost:9200/searchguard/ac/ac?pretty' -d '
{"acl": [
    {
      "filters_bypass": ,
      "filters_execute": ["*"]
    },
    {
      "roles": ["doc"],
      "indices": ["biglog-crazw-*"],
      "filters_bypass": ,
      "filters_execute": ["dlsfilter.*"]
    },

    {
      "roles": ["root"],
      "indices": ["*"],
      "filters_bypass": ["*"],
      "filters_execute":
    }
    
  ]}'

But when I login with the root user to access kibana4.1 ,it show me that:

When I delete the conf of dlsfilter , it will be ok!

Can you give some suggets, What is wrong with my conf file?
Thank you so much!

--
You received this message because you are subscribed to the Google Groups "Search Guard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/bc59fbc4-3f76-4693-b9a6-2212da5fdf30%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Ok, Thank you so much. Look forward to it.

···

On Friday, June 12, 2015 at 4:24:07 AM UTC+8, SG wrote:

we will provide a guide, how to setup and configure search guard with kibana, soon

Am 05.06.2015 um 13:27 schrieb Lingxiao Xia lingxi...@dragonlaw.com.hk:

I’m getting the same error. But if i sign in with as ‘admin’ i get: “Courier Fetch: resp is undefined”. querying against elasticsearch directly seem to be working, and the filters work great so thanks :smiley:

Oops!

Looks like something went wrong. Refreshing may do the trick.

or clear your session

Fatal Error

Courier Fetch: resp is undefined

callResponseHandlers/<@http://127.0.0.1:9548/index.js?_b=5930:42957:1

Promise.try@

http://127.0.0.1:9548/index.js?_b=5930:46205:23

Promise.map/<@

http://127.0.0.1:9548/index.js?_b=5930:46183:16

Promise.map@

http://127.0.0.1:9548/index.js?_b=5930:46182:26

callResponseHandlers@

http://127.0.0.1:9548/index.js?_b=5930:42950:1

fetchWithStrategy/<@

http://127.0.0.1:9548/index.js?_b=5930:43068:16

qFactory/defer/deferred.promise.then/wrappedCallback@

http://127.0.0.1:9548/index.js?_b=5930:20873:31

qFactory/defer/deferred.promise.then/wrappedCallback@

http://127.0.0.1:9548/index.js?_b=5930:20873:31

qFactory/ref/<.then/<@

http://127.0.0.1:9548/index.js?_b=5930:20959:26

$RootScopeProvider/this.$get</Scope.prototype.$eval@

http://127.0.0.1:9548/index.js?_b=5930:22002:16

$RootScopeProvider/this.$get</Scope.prototype.$digest@

http://127.0.0.1:9548/index.js?_b=5930:21814:15

$RootScopeProvider/this.$get</Scope.prototype.$apply@

http://127.0.0.1:9548/index.js?_b=5930:22106:13

done@

http://127.0.0.1:9548/index.js?_b=5930:17641:34

completeRequest@

http://127.0.0.1:9548/index.js?_b=5930:17855:7

createHttpBackend/</xhr.onreadystatechange@http://127.0.0.1:9548/index.js?_b=5930:17794:1

On Friday, June 5, 2015 at 4:35:04 PM UTC+8, in...@search-guard.com wrote:

can you post (or mail) debug logs?

Am Donnerstag, 4. Juni 2015 20:09:56 UTC+2 schrieb Crazw jia:

My elasticsearch.yml is:

###################### search guard ########################

searchguard.allow_all_from_loopback: true

searchguard.authentication.settingsdb.user.root: biglog.org

searchguard.authentication.settingsdb.user.crazw: jia0926

searchguard.authentication.settingsdb.user.crazw3: jia0926

searchguard.authentication.authorization.settingsdb.roles.root: [“root”]

searchguard.authentication.authorization.settingsdb.roles.crazw: [“crazw”]

searchguard.authentication.authorization.settingsdb.roles.crazw3: [“doc”]

searchguard.dlsfilter.names: [“b”]

searchguard.dlsfilter.b: [“term”, “tags”,“file”, “true”]

My searchguard indices is :

curl -XPUT ‘http://localhost:9200/searchguard/ac/ac?pretty’ -d ’

{“acl”: [

{
  "filters_bypass": [],
  "filters_execute": ["*"]
},
{
  "roles": ["doc"],
  "indices": ["biglog-crazw-*"],
  "filters_bypass": [],
  "filters_execute": ["dlsfilter.*"]
},
{
  "roles": ["root"],
  "indices": ["*"],
  "filters_bypass": ["*"],
  "filters_execute": []
}

]}’

But when I login with the root user to access kibana4.1 ,it show me that:

When I delete the conf of dlsfilter , it will be ok!

Can you give some suggets, What is wrong with my conf file?

Thank you so much!


You received this message because you are subscribed to the Google Groups “Search Guard” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/bc59fbc4-3f76-4693-b9a6-2212da5fdf30%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

Any hope with the guide? I’m still having issues with kibana and “Courier Fetch: Cannot read property ‘timed_out’ of undefined”

···

On Thursday, June 11, 2015 at 1:24:07 PM UTC-7, SG wrote:

we will provide a guide, how to setup and configure search guard with kibana, soon

Am 05.06.2015 um 13:27 schrieb Lingxiao Xia lingxi...@dragonlaw.com.hk:

I’m getting the same error. But if i sign in with as ‘admin’ i get: “Courier Fetch: resp is undefined”. querying against elasticsearch directly seem to be working, and the filters work great so thanks :smiley:

Oops!

Looks like something went wrong. Refreshing may do the trick.

or clear your session

Fatal Error

Courier Fetch: resp is undefined

callResponseHandlers/<@http://127.0.0.1:9548/index.js?_b=5930:42957:1

Promise.try@

http://127.0.0.1:9548/index.js?_b=5930:46205:23

Promise.map/<@

http://127.0.0.1:9548/index.js?_b=5930:46183:16

Promise.map@

http://127.0.0.1:9548/index.js?_b=5930:46182:26

callResponseHandlers@

http://127.0.0.1:9548/index.js?_b=5930:42950:1

fetchWithStrategy/<@

http://127.0.0.1:9548/index.js?_b=5930:43068:16

qFactory/defer/deferred.promise.then/wrappedCallback@

http://127.0.0.1:9548/index.js?_b=5930:20873:31

qFactory/defer/deferred.promise.then/wrappedCallback@

http://127.0.0.1:9548/index.js?_b=5930:20873:31

qFactory/ref/<.then/<@

http://127.0.0.1:9548/index.js?_b=5930:20959:26

$RootScopeProvider/this.$get</Scope.prototype.$eval@

http://127.0.0.1:9548/index.js?_b=5930:22002:16

$RootScopeProvider/this.$get</Scope.prototype.$digest@

http://127.0.0.1:9548/index.js?_b=5930:21814:15

$RootScopeProvider/this.$get</Scope.prototype.$apply@

http://127.0.0.1:9548/index.js?_b=5930:22106:13

done@

http://127.0.0.1:9548/index.js?_b=5930:17641:34

completeRequest@

http://127.0.0.1:9548/index.js?_b=5930:17855:7

createHttpBackend/</xhr.onreadystatechange@http://127.0.0.1:9548/index.js?_b=5930:17794:1

On Friday, June 5, 2015 at 4:35:04 PM UTC+8, in...@search-guard.com wrote:

can you post (or mail) debug logs?

Am Donnerstag, 4. Juni 2015 20:09:56 UTC+2 schrieb Crazw jia:

My elasticsearch.yml is:

###################### search guard ########################

searchguard.allow_all_from_loopback: true

searchguard.authentication.settingsdb.user.root: biglog.org

searchguard.authentication.settingsdb.user.crazw: jia0926

searchguard.authentication.settingsdb.user.crazw3: jia0926

searchguard.authentication.authorization.settingsdb.roles.root: [“root”]

searchguard.authentication.authorization.settingsdb.roles.crazw: [“crazw”]

searchguard.authentication.authorization.settingsdb.roles.crazw3: [“doc”]

searchguard.dlsfilter.names: [“b”]

searchguard.dlsfilter.b: [“term”, “tags”,“file”, “true”]

My searchguard indices is :

curl -XPUT ‘http://localhost:9200/searchguard/ac/ac?pretty’ -d ’

{“acl”: [

{
  "filters_bypass": [],
  "filters_execute": ["*"]
},
{
  "roles": ["doc"],
  "indices": ["biglog-crazw-*"],
  "filters_bypass": [],
  "filters_execute": ["dlsfilter.*"]
},
{
  "roles": ["root"],
  "indices": ["*"],
  "filters_bypass": ["*"],
  "filters_execute": []
}

]}’

But when I login with the root user to access kibana4.1 ,it show me that:

When I delete the conf of dlsfilter , it will be ok!

Can you give some suggets, What is wrong with my conf file?

Thank you so much!


You received this message because you are subscribed to the Google Groups “Search Guard” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/bc59fbc4-3f76-4693-b9a6-2212da5fdf30%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.