Is it still possible to disable the search guard plugin?

I’m on ES / SG 5.2.2 and I’ve put searchguard.enabled: false in my elasticsearch config AND my kibana config. Yet, I get:

org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [searchguard.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.2.jar:5.2.2]

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.2.jar:5.2.2]

``

? Please and thanks.

Hi,

it was never possible to disable Search Guard by a configuration, “searchguard.enabled” is not a valid config key. This feature is planned for SG6 though. But at the moment you’d need to remove the plugin as discussed in https://groups.google.com/forum/#!topic/search-guard/YkSSN-vZzkc

···

On Thursday, August 3, 2017 at 11:58:53 AM UTC+2, mcostantini@np6.com wrote:

I’m on ES / SG 5.2.2 and I’ve put searchguard.enabled: false in my elasticsearch config AND my kibana config. Yet, I get:

org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [searchguard.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.2.jar:5.2.2]

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.2.jar:5.2.2]

``

? Please and thanks.

Thank you

···

On Thursday, August 3, 2017 at 6:41:22 PM UTC+2, Jochen Kressin wrote:

Hi,

it was never possible to disable Search Guard by a configuration, “searchguard.enabled” is not a valid config key. This feature is planned for SG6 though. But at the moment you’d need to remove the plugin as discussed in https://groups.google.com/forum/#!topic/search-guard/YkSSN-vZzkc

On Thursday, August 3, 2017 at 11:58:53 AM UTC+2, mcost...@np6.com wrote:

I’m on ES / SG 5.2.2 and I’ve put searchguard.enabled: false in my elasticsearch config AND my kibana config. Yet, I get:

org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [searchguard.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.2.jar:5.2.2]

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.2.jar:5.2.2]

``

? Please and thanks.

Just to keep you updated, we’ve backported the new setting to disable SG to 5.x. In SG v15 you can set in elasticsearch.yml:

searchguard.disabled: true

Which will disable SG completely without the need to delete the plugin or remove any SG related config entries in elasticsearch.yml.

According to our EOL policy this feature is available for all 5.5.x and 5.4.3 version of SG/ES.

Hope this helps!

···

On Friday, August 4, 2017 at 9:27:37 AM UTC+2, mcostantini@np6.com wrote:

Thank you

On Thursday, August 3, 2017 at 6:41:22 PM UTC+2, Jochen Kressin wrote:

Hi,

it was never possible to disable Search Guard by a configuration, “searchguard.enabled” is not a valid config key. This feature is planned for SG6 though. But at the moment you’d need to remove the plugin as discussed in https://groups.google.com/forum/#!topic/search-guard/YkSSN-vZzkc

On Thursday, August 3, 2017 at 11:58:53 AM UTC+2, mcost...@np6.com wrote:

I’m on ES / SG 5.2.2 and I’ve put searchguard.enabled: false in my elasticsearch config AND my kibana config. Yet, I get:

org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [searchguard.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.2.jar:5.2.2]

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.2.jar:5.2.2]

``

? Please and thanks.

A great move in improving the flexibility of the tool. Thanks very much.

···

On Wednesday, August 16, 2017 at 11:12:16 PM UTC+2, Jochen Kressin wrote:

Just to keep you updated, we’ve backported the new setting to disable SG to 5.x. In SG v15 you can set in elasticsearch.yml:

searchguard.disabled: true

Which will disable SG completely without the need to delete the plugin or remove any SG related config entries in elasticsearch.yml.

According to our EOL policy this feature is available for all 5.5.x and 5.4.3 version of SG/ES.

Hope this helps!

On Friday, August 4, 2017 at 9:27:37 AM UTC+2, mcost...@np6.com wrote:

Thank you

On Thursday, August 3, 2017 at 6:41:22 PM UTC+2, Jochen Kressin wrote:

Hi,

it was never possible to disable Search Guard by a configuration, “searchguard.enabled” is not a valid config key. This feature is planned for SG6 though. But at the moment you’d need to remove the plugin as discussed in https://groups.google.com/forum/#!topic/search-guard/YkSSN-vZzkc

On Thursday, August 3, 2017 at 11:58:53 AM UTC+2, mcost...@np6.com wrote:

I’m on ES / SG 5.2.2 and I’ve put searchguard.enabled: false in my elasticsearch config AND my kibana config. Yet, I get:

org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [searchguard.enabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.2.2.jar:5.2.2]

es_1 | at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.2.2.jar:5.2.2]

``

? Please and thanks.