How to disable error message in Kibana?


Problem description:
Elasticsearch version: 6.8.10
Kibana version (if relevant): 6.8.10

Describe the issue:

When user go to Discover in Kibana and he don’t have access to some data, he receive error:

Discover: no permissions for [indices:data/read/search] and User [name=user, roles=, requestedTenant=]
Error: Request to Elasticsearch failed: {“error”:{“root_cause”:[{“type”:“security_exception”,“reason”:“no permissions for [indices:data/read/search] and User [name=user, roles=, requestedTenant=]”}],“type”:“security_exception”,“reason”:“no permissions for [indices:data/read/search] and User [name=user, roles=, requestedTenant=]”},“status”:403}

How to disable this kind of messages so it will not be visible to the user?

Hi. There is no way to disable these messages. You can use multitenancy to introduce user scopes and minimize these kinds of messages. But in the end, a user must have proper permission if he wants to access something.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.