Getting error [FuxBHf8] No permissions for [indices:admin/get] even if permission is set

Hello,

I keep getting the error in the subjet even if i set the indices:admin/get permission for the current user and role.

I am running the following versions:

Search Guard version: search-guard-6:6.5.2-24.0

Elasticsearch version: 6.5.2

java version “1.8.0_191” on Windows 10

Kibana Plugin: 6.5.3-17

Thanks very much

Giuseppe Lio

Sorry, that'as far to few informations to help you.

Please attach all your sg_*.yml files and elasticsearch.yml and tell us when do you get the "No permissions for [indices:admin/get]" message.

···

Am 01.02.2019 um 11:44 schrieb Giuseppe Lio <liogiuseppe@gmail.com>:

Hello,
I keep getting the error in the subjet even if i set the indices:admin/get permission for the current user and role.

I am running the following versions:

Search Guard version: search-guard-6:6.5.2-24.0
Elasticsearch version: 6.5.2
java version "1.8.0_191" on Windows 10
Kibana Plugin: 6.5.3-17

Thanks very much

Giuseppe Lio

--
You received this message because you are subscribed to the Google Groups "Search Guard Community Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/06cb48ab-d580-4a3a-8f8c-a96a91de3aa0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hello,
I get the error when performin a Get Alias request on all indexes.

As for the configuration, I added the user and the role I am logging in with using Kibana SearchGuard plugin and honestly I cannot understand where it stores the config changes.

I tried to perform a “match_all” query on the SearchGuard index with Kibana but it returned no result even if there are 6 documents in the index.

Anyway, I log with the following user:

{

“roles”: [

“sg_own_index_cl_monitor”

],

“password”: “”,

“attributes”: {}

}

The role is defined as:

{

“cluster”: [

“CLUSTER_MONITOR”,

“CLUSTER_COMPOSITE_OPS”,

“indices:admin/get”

],

“indices”: {

“cobalt-dev*”: {

“*”: [

“INDICES_ALL”,

“MANAGE_ALIASES”,

“indices:admin/get”

]

}

},

“tenants”: {}

}

Thanks very much for your help.

Giuseppe Lio

···

Il giorno domenica 3 febbraio 2019 15:21:07 UTC+1, Search Guard ha scritto:

Sorry, that’as far to few informations to help you.

Please attach all your sg_*.yml files and elasticsearch.yml and tell us when do you get the “No permissions for [indices:admin/get]” message.

Am 01.02.2019 um 11:44 schrieb Giuseppe Lio liogi...@gmail.com:

Hello,

I keep getting the error in the subjet even if i set the indices:admin/get permission for the current user and role.

I am running the following versions:

Search Guard version: search-guard-6:6.5.2-24.0

Elasticsearch version: 6.5.2

java version “1.8.0_191” on Windows 10

Kibana Plugin: 6.5.3-17

Thanks very much

Giuseppe Lio


You received this message because you are subscribed to the Google Groups “Search Guard Community Forum” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/06cb48ab-d580-4a3a-8f8c-a96a91de3aa0%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.