Elastic search will not start after I change data path.

I configured Elasticsearch with Search Guard SSL and Search Guard and am able to run it correctly with the default data path setting, i.e., path.data commented out in elasticsearch.yml. The default data path is /var/lib/elasticsearch, and i see that it creates a nodes directory in there.

Now if I uncomment out the path.data line in elasticsearch.yml, set it to a new path, and restart elasticsearch, I get “search guard index not healthy yet”.

If I change it back to the default, that is comment out the path.data in elasticsearch.yml, and restart elasticsearch, it works again.

The new path is owned by elasticsearch user and group, and I do see a nodes directory created in the new path, so it’s not a permissions issue.

Is there something else I need to do in Search Guard if I change the data path than just restarting elasticsearch?

I see these in the logs

[2016-10-04 14:08:55,085][WARN ][com.floragunn.searchguard.action.configupdate.TransportConfigUpdateAction] [ip-10-22-x-x] searchguard index not healthy yet, we try again … (Reason: timeout)

[2016-10-04 14:14:35,840][ERROR][com.floragunn.searchguard.auth.BackendRegistry] Not yet initialized

···

On Tuesday, October 4, 2016 at 1:01:39 PM UTC-4, ZillaYT wrote:

I configured Elasticsearch with Search Guard SSL and Search Guard and am able to run it correctly with the default data path setting, i.e., path.data commented out in elasticsearch.yml. The default data path is /var/lib/elasticsearch, and i see that it creates a nodes directory in there.

Now if I uncomment out the path.data line in elasticsearch.yml, set it to a new path, and restart elasticsearch, I get “search guard index not healthy yet”.

If I change it back to the default, that is comment out the path.data in elasticsearch.yml, and restart elasticsearch, it works again.

The new path is owned by elasticsearch user and group, and I do see a nodes directory created in the new path, so it’s not a permissions issue.

Is there something else I need to do in Search Guard if I change the data path than just restarting elasticsearch?

run sgadmin.sh again after changing the path

···

Am 04.10.2016 um 19:01 schrieb ZillaYT <zilla62@gmail.com>:

I configured Elasticsearch with Search Guard SSL and Search Guard and am able to run it correctly with the default data path setting, i.e., path.data commented out in elasticsearch.yml. The default data path is /var/lib/elasticsearch, and i see that it creates a nodes directory in there.

Now if I uncomment out the path.data line in elasticsearch.yml, set it to a new path, and restart elasticsearch, I get "search guard index not healthy yet".

If I change it back to the default, that is comment out the path.data in elasticsearch.yml, and restart elasticsearch, it works again.

The new path is owned by elasticsearch user and group, and I do see a nodes directory created in the new path, so it's not a permissions issue.

Is there something else I need to do in Search Guard if I change the data path than just restarting elasticsearch?

--
You received this message because you are subscribed to the Google Groups "Search Guard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/e7c0a9fb-586e-4a29-9a7e-214235fa62ad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

So the order of events is (I’m asking)?

  • Leave ES running

  • Change data path in /etc/elasticsearch/elasticsearch.yml

  • Rerun sgadmin.sh

  • Restart ES (Is this needed ???)

Thanks.

···

On Tuesday, October 4, 2016 at 2:06:02 PM UTC-4, SG wrote:

run sgadmin.sh again after changing the path

Am 04.10.2016 um 19:01 schrieb ZillaYT zil...@gmail.com:

I configured Elasticsearch with Search Guard SSL and Search Guard and am able to run it correctly with the default data path setting, i.e., path.data commented out in elasticsearch.yml. The default data path is /var/lib/elasticsearch, and i see that it creates a nodes directory in there.

Now if I uncomment out the path.data line in elasticsearch.yml, set it to a new path, and restart elasticsearch, I get “search guard index not healthy yet”.

If I change it back to the default, that is comment out the path.data in elasticsearch.yml, and restart elasticsearch, it works again.

The new path is owned by elasticsearch user and group, and I do see a nodes directory created in the new path, so it’s not a permissions issue.

Is there something else I need to do in Search Guard if I change the data path than just restarting elasticsearch?


You received this message because you are subscribed to the Google Groups “Search Guard” group.

To unsubscribe from this group and stop receiving emails from it, send an email to search-guard...@googlegroups.com.

To post to this group, send email to search...@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/e7c0a9fb-586e-4a29-9a7e-214235fa62ad%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.