Connecting Apache Storm to ES (secured through searchguard)

Hi, I am trying to connect a storm topology to a secure ES cluster (secured using search guard)

I have added,

es.net.ssl = true

es.net.allow.self.signed=true

ssl keystore location and password are provided as well, however, it always complains :

Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

at sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:146) ~[?:1.8.0_73]

at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:131) ~[?:1.8.0_73]

at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280) ~[?:1.8.0_73]

at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:382) ~[?:1.8.0_73]

at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:230) ~[?:1.8.0_73]

at sun.security.validator.Validator.validate(Validator.java:260) ~[?:1.8.0_73]

Any suggestions are greatly appreciated.

Can you please provide you elasticsearch.yml as well as the complete config on the storm side?

···

Am 29.09.2016 um 22:28 schrieb Shoeb Amer <amer966us@gmail.com>:

Hi, I am trying to connect a storm topology to a secure ES cluster (secured using search guard)

I have added,

es.net.ssl = true
es.net.allow.self.signed=true

ssl keystore location and password are provided as well, however, it always complains :
Caused by: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
        at sun.security.provider.certpath.SunCertPathBuilder.build(SunCertPathBuilder.java:146) ~[?:1.8.0_73]
        at sun.security.provider.certpath.SunCertPathBuilder.engineBuild(SunCertPathBuilder.java:131) ~[?:1.8.0_73]
        at java.security.cert.CertPathBuilder.build(CertPathBuilder.java:280) ~[?:1.8.0_73]
        at sun.security.validator.PKIXValidator.doBuild(PKIXValidator.java:382) ~[?:1.8.0_73]
        at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:230) ~[?:1.8.0_73]
        at sun.security.validator.Validator.validate(Validator.java:260) ~[?:1.8.0_73]

Any suggestions are greatly appreciated.

--
You received this message because you are subscribed to the Google Groups "Search Guard" group.
To unsubscribe from this group and stop receiving emails from it, send an email to search-guard+unsubscribe@googlegroups.com.
To post to this group, send email to search-guard@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/search-guard/2ae3acb3-a6b0-40fa-9dad-bb5b5e49c551%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.