[Bug] Preferred Tenant setting does not work

Hi,

the preferred tenant setting does not seem to work as expected on the latest version of SG with Kibana/ES 7.6.2
As long as the “Private” tenant is enabled it will always be selected first for a new user on first login.

This is the relevant part in kibana.yml:

searchguard:
  multitenancy:
    enabled: true
    tenants:
      enable_global: false
      enable_private: true
      preferred:
        - ABC
        - EFG
        - Private

Given a user test with read access to ABC I’d expect it to be selected as the initial tenant, but Private is selected instead (tried multiple times with newly created accounts).

It is a bug, I can reproduce it. I add this to the queue of the issues to resolve.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.