Can't start single 7.x node bound to 0.0.0.0 (RC1) [solved]

I’m trying do do some testing using 7.0.0-35.0.0-rc1 on a single node, but it’s not bound to localhost so the ES bootstrap config doesn’t apply and I’m running into problems with zen2 discovery.

[2019-05-06T17:31:53,837][WARN ][o.e.c.c.ClusterFormationFailureHelper] [test-node] master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [test-node] to bootstrap a cluster: have discovered []; discovery will continue using [127.0.0.1:9301, 127.0.0.1:9302, 127.0.0.1:9303, 127.0.0.1:9304, [::1]:9300, [::1]:9301, [::1]:9302, [::1]:9303, [::1]:9304] from hosts providers and [{test-node}{XSPOtnhMSaG633-Z61zfqw}{8nQYTLo3QuWL_tvkpXU4vA}{127.0.0.1}{127.0.0.1:9300}{ml.machine_memory=8371200000, xpack.installed=true, ml.max_open_jobs=20}] from last-known cluster state; node term 0, last-accepted version 0 in term 0

Normally I’d think this is just me not understanding zen2 properly, but if I remove Searchguard I can get the node to start. Replacing Searchguard and restarting the node causes the same issue again.

Am I still missing something with zen2, or is there some kind of startup race condition here with Searchguard?

Can you share your elasticsearch.yml?

The following configs works for me

network.host: 0.0.0.0
node.name: smoketestnode
cluster.initial_master_nodes: smoketestnode
1 Like

I’m still not entirely sure what I did wrong, as I went through a lot of zen2 config variations before posting here, but adapting your example above gets the node started up just fine.

I tried with cluster.initial_master_nodes, but obviously something else in the config was upsetting it as it didn’t recognise itself as a master. I unfortunately can’t point out what the issue was after that amount of config thrash.

Thanks for the help, even though it was unrelated to Searchguard!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.